watchcat: update to support procd
[feed/packages.git] / utils / watchcat / Makefile
index 0cbf11ddab01022a4bd675179d489c04c76ab249..cb80a6a10ee9c38dae9431e1709ba6b187f1e96d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=watchcat
 PKG_VERSION:=1
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 
 PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
 PKG_LICENSE:=GPL-2.0
@@ -19,16 +19,16 @@ include $(INCLUDE_DIR)/package.mk
 define Package/watchcat
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=Enable the configuration of programed reboots
+  TITLE:=Enable the configuration of programmed reboots or network interface restarts
   PKGARCH:=all
 endef
 
 define Package/watchcat/description
-Allows to configure a periodically reboot, or after losing internet connectivity. Configured trough UCI /etc/config/system.
+Restart network interfaces or reboot if pings to hosts fail, or set up periodic reboots. Configured via UCI /etc/config/watchcat
 endef
 
 define Package/watchcat/conffiles
-/etc/config/system
+/etc/config/watchcat
 endef
 
 define Build/Compile
@@ -36,11 +36,13 @@ endef
 
 define Package/watchcat/install
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/initd_watchcat $(1)/etc/init.d/watchcat
+       $(INSTALL_BIN) ./files/watchcat.init $(1)/etc/init.d/watchcat
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) ./files/watchcat.sh $(1)/usr/bin/watchcat.sh
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/watchcat.config $(1)/etc/config/watchcat
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/uci_defaults_watchcat $(1)/etc/uci-defaults/50-watchcat
+       $(INSTALL_BIN) ./files/migrate-watchcat $(1)/etc/uci-defaults/migrate-watchcat
 endef
 
 $(eval $(call BuildPackage,watchcat))