Add xfce packages.
[openwrt/svn-archive/feeds.git] / xfce / libs / libxfcegui4 / Makefile
diff --git a/xfce/libs/libxfcegui4/Makefile b/xfce/libs/libxfcegui4/Makefile
new file mode 100644 (file)
index 0000000..aff6d4e
--- /dev/null
@@ -0,0 +1,75 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libxfcegui4
+PKG_VERSION:=4.5.93
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.tx-us.xfce.org/archive/xfce-$(PKG_VERSION)/src/
+PKG_MD5SUM:=e8c760abcd08df81abe4a2f94ced26aa
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+       -I$(STAGING_DIR)/usr/lib/libintl/include/
+
+TARGET_CFLAGS+= \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib/
+
+define Package/libxfcegui4
+  SECTION:=xorg-framework
+  CATEGORY:=Xorg
+  SUBMENU:=framework
+  TITLE:=libxfcegui4
+  DEPENDS:=+libxfce4util +gtk2 +libglade +libxfconf
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/xfce4/libxfcegui4,include/xfce4/libxfce4kbd-private}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/xfce4/libxfcegui4/* \
+               $(1)/usr/include/xfce4/libxfcegui4
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/xfce4/libxfce4kbd-private/* \
+               $(1)/usr/include/xfce4/libxfce4kbd-private/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.{la,so*,a} \
+               $(1)/usr/lib/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libxfcegui4/install
+       $(INSTALL_DIR) $(1)/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/* \
+               $(1)/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/
+
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/lib/libglade/2.0
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libglade/2.0/*.so \
+               $(1)/usr/lib/libglade/2.0/
+
+       $(INSTALL_DIR) $(1)/usr/share/icons/hicolor
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/share/icons/hicolor/* \
+               $(1)/usr/share/icons/hicolor/
+endef
+
+$(eval $(call BuildPackage,libxfcegui4))