kamailio-5.x: bump to version 5.1.1
authorSebastian Kemper <sebastian_ml@gmx.net>
Thu, 8 Feb 2018 21:26:49 +0000 (22:26 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 10 Feb 2018 14:07:45 +0000 (15:07 +0100)
- dictionary.kamailio & kamailio-basic.cfg are gone, remove from
  Makefilei accordingly
- Install the config files from PKG_INSTALL_DIR
- Use $(INSTALL_CONF) for config files
- Remove gratuitous directory creation
- Refresh 050-fix-kamailio-utils.patch
- Remove src/modules/cnxcc/Makefile change from 120-libevent-libs.patch
  as $(EXTRA_LIBS) has been removed from Makefile in previous commit

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/kamailio-5.x/Makefile
net/kamailio-5.x/patches/050-fix-kamailio-utils.patch
net/kamailio-5.x/patches/120-libevent-libs.patch

index 092b387c0c0e430ad828528ff06d8a24bad955f4..6bfc7f7a62f6bea592070781ebe2a9f002eb09c7 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kamailio5
-PKG_VERSION:=5.0.4
-PKG_RELEASE:=3
+PKG_VERSION:=5.1.1
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://www.kamailio.org/pub/kamailio/$(PKG_VERSION)/src
 PKG_SOURCE:=kamailio-$(PKG_VERSION)$(PKG_VARIANT)_src.tar.gz
-PKG_HASH:=71f1b560721f9c2bed9f7cbd3b4c08d8defd2daa8fd28ce55d3938781a654a13
+PKG_HASH:=96f15fd639d6ea2f4f9921e83ecddff0ac42732f2709bcf7269d591952676fc4
 PKG_USE_MIPS16:=0
 
 PKG_LICENSE:=GPL-2.0+
@@ -47,7 +47,6 @@ endef
 define Package/kamailio5/conffiles
 /etc/default/kamailio
 /etc/kamailio/kamailio.cfg
-/etc/kamailio/dictionary.kamailio
 /etc/kamailio/kamctlrc
 endef
 
@@ -61,21 +60,17 @@ define Package/kamailio5/install
                $(PKG_INSTALL_DIR)/usr/lib/kamailio/lib*.so* \
                $(1)/usr/lib/kamailio/
        $(INSTALL_DIR) $(1)/etc/kamailio
-       $(CP) \
-               $(PKG_BUILD_DIR)/etc/{dictionary.kamailio,kamailio.cfg,kamailio-basic.cfg} \
-               $(1)/etc/kamailio/
-       $(CP) \
-               $(PKG_BUILD_DIR)/utils/kamctl/kamctlrc \
+       $(INSTALL_CONF) \
+               $(PKG_INSTALL_DIR)/etc/kamailio/{kamailio.cfg,kamctlrc} \
                $(1)/etc/kamailio/
        $(INSTALL_DIR) $(1)/etc/default
-       $(CP) \
+       $(INSTALL_CONF) \
                ./files/kamailio.default \
                $(1)/etc/default/kamailio
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) \
                ./files/kamailio.init \
                $(1)/etc/init.d/kamailio
-       $(INSTALL_DIR) $(1)/usr/lib/kamailio
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/kamailio/kamctl \
                $(1)/usr/lib/kamailio/
index 921207374e3e0967fe34ab2007982821d5c820a5..afd17331a2f1f3756014159a65d1499f98b162be 100644 (file)
@@ -8,7 +8,7 @@
  #
 --- a/utils/kamctl/kamctlrc
 +++ b/utils/kamctl/kamctlrc
-@@ -151,3 +151,6 @@
+@@ -160,3 +160,6 @@
  ## Extra start options - default is: not set
  # example: start Kamailio with 64MB share memory: STARTOPTIONS="-m 64"
  # STARTOPTIONS=
@@ -23,8 +23,8 @@
  #
  # control tool for maintaining Kamailio databases
  #
---- kamailio5-5.0.2/utils/kamctl/kamdbctl.base 2017-06-26 13:57:13.000000000 +0200
-+++ kamailio5-x/utils/kamctl/kamdbctl.base     2017-08-13 20:17:54.033561438 +0200
+--- a/utils/kamctl/kamdbctl.base
++++ b/utils/kamctl/kamdbctl.base
 @@ -33,19 +33,19 @@ INSTALL_DBUID_TABLES=${INSTALL_DBUID_TAB
  
  # Used by dbtext and db_berkeley to define tables to be created, used by
index cd50a3cae699c1bc20c75a47988cab7e18598a89..b3aa328a061ab558c1128140a1eff9852c55e203 100644 (file)
@@ -1,14 +1,3 @@
---- a/src/modules/cnxcc/Makefile
-+++ b/src/modules/cnxcc/Makefile
-@@ -45,7 +45,7 @@ else
- endif
- DEFS+=$(HIREDISDEFS) $(LEVENTDEFS)
--LIBS=$(HIREDISLIBS) $(LEVENTLIBS)
-+LIBS=$(HIREDISLIBS) $(LEVENTLIBS) $(EXTRA_LIBS)
- DEFS+=-DOPENSER_MOD_INTERFACE
- SERLIBPATH=../../lib
 --- a/src/modules/janssonrpcc/netstring.h
 +++ b/src/modules/janssonrpcc/netstring.h
 @@ -24,6 +24,7 @@