python-dns: Update to 2.4.1
authorJeffery To <jeffery.to@gmail.com>
Thu, 27 Jul 2023 18:18:52 +0000 (02:18 +0800)
committerTianling Shen <cnsztl@gmail.com>
Thu, 3 Aug 2023 17:58:29 +0000 (01:58 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-dns/Makefile

index f303733b657213a7b7204ae09d8e73a9c144a435..03fbffee67a0972eb44f41c0b6d30e4026f3a5d2 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-dns
-PKG_VERSION:=2.3.0
+PKG_VERSION:=2.4.1
 PKG_RELEASE:=1
 
 PYPI_NAME:=dnspython
-PKG_HASH:=224e32b03eb46be70e12ef6d64e0be123a64e621ab4c0822ff6d450d52a540b9
+PKG_HASH:=c33971c79af5be968bb897e95c2448e11a645ee84d93b265ce0b7aabe5dfdca8
 
 PKG_LICENSE:=ISC
 PKG_LICENSE_FILES:=LICENSE
@@ -28,13 +28,15 @@ define Package/python3-dns
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=dnspython
-  URL:=http://www.dnspython.org/
+  TITLE:=DNS toolkit
+  URL:=https://www.dnspython.org/
   DEPENDS:=+python3
 endef
 
 define Package/python3-dns/description
- dnspython is a DNS toolkit for Python. It supports almost all record types. It can be used for queries, zone transfers, and dynamic updates. It supports TSIG authenticated messages and EDNS0.
+dnspython is a DNS toolkit for Python. It supports almost all record
+types. It can be used for queries, zone transfers, and dynamic updates.
+It supports TSIG authenticated messages and EDNS0.
 endef
 
 $(eval $(call Py3Package,python3-dns))