git: update to version 2.34.1
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 30 Dec 2021 17:24:39 +0000 (18:24 +0100)
committerRosen Penev <rosenp@gmail.com>
Wed, 19 Jan 2022 02:06:07 +0000 (18:06 -0800)
- Refreshed patches

- Release notes 2.34.0:
https://github.com/git/git/blob/2ae0a9cb8298185a94e5998086f380a355dd8907/Documentation/RelNotes/2.34.0.txt

- Release notes 2.34.1:
https://github.com/git/git/blob/2ae0a9cb8298185a94e5998086f380a355dd8907/Documentation/RelNotes/2.34.1.txt

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
net/git/Makefile
net/git/patches/200-imapsend_without_curl.patch
net/git/patches/310-fix-uname-detection-for-crosscompiling

index a6b5309f713fabc0e95141aa998bd3a7c4ec351c..ee4620bce073811f0ad5261edee8949873af2f00 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
-PKG_VERSION:=2.33.1
+PKG_VERSION:=2.34.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/scm/git/
-PKG_HASH:=e054a6e6c2b088bd1bff5f61ed9ba5aa91c9a3cd509539a4b41c5ddf02201f2f
+PKG_HASH:=3a0755dd1cfab71a24dd96df3498c29cd0acd13b04f3d08bf933e81286db802c
 
 PKG_LICENSE:=GPL-2.0-or-later
 PKG_LICENSE_FILES:=COPYING
index 38c17c25cf85d9738176b5196a2a66a328f0d793..126058faa04a51fe4c71b655d3dd26afe1979eb4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -1448,7 +1448,7 @@ else
+@@ -1436,7 +1436,7 @@ else
        endif
        curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
        ifeq "$(curl_check)" "072200"
index 0402a8f4150f5a58c6f7a82ac71e10f0a6777cf8..4b884d2984d843b22564ace775a41575684f83a5 100644 (file)
@@ -39,5 +39,5 @@ Signed-off-by: Mauro Condarelli <mc5686 at mclink.it>
 +uname_P ?= $(shell sh -c 'uname -p 2>/dev/null || echo not')
 +uname_V ?= $(shell sh -c 'uname -v 2>/dev/null || echo not')
  
- ifdef MSVC
-       # avoid the MingW and Cygwin configuration sections
+ ifneq ($(findstring MINGW,$(uname_S)),)
+       uname_S := MINGW