postgresql: fix compilation with GCC4 12272/head
authorRosen Penev <rosenp@gmail.com>
Sun, 24 May 2020 02:15:52 +0000 (19:15 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 24 May 2020 02:15:52 +0000 (19:15 -0700)
The minimum version of GCC according to prereq-build.mk is 4.8 which
defaults to gnu89. This breaks the host build when the host GCC is less
than 5, which defaults to gnu99. Add a simple CFLAG to fix.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/postgresql/Makefile

index 77e0f1bcec262c8009846012750a08513268afbf..c33bbd4426fd9738a4f0ba0fedd8975d4764f7b1 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
 PKG_VERSION:=12.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=PostgreSQL
 PKG_CPE_ID:=cpe:/a:postgresql:postgresql
@@ -156,6 +156,8 @@ CONFIGURE_ARGS += \
                        --enable-depend \
                        $(if $(CONFIG_arc),--disable-spinlocks)
 
+HOST_CFLAGS += -std=gnu99
+
 # Need a native zic and pg_config for build
 define Host/Compile
        +$(HOST_MAKE_VARS) MAKELEVEL=0 $(MAKE) -C $(HOST_BUILD_DIR)/src/bin/pg_config CC="$(HOSTCC)"