strongswan: rename config functions
authorPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 27 Jun 2021 22:26:39 +0000 (16:26 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 27 Jun 2021 22:31:31 +0000 (16:31 -0600)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/strongswan/Makefile
net/strongswan/files/swanctl.init

index 596bd8e385a642a6ec33c2b39064d2d69ea954b2..a1eb7b8affca0bb76c2b2d14a60510459bc6370e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.2
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
index 884fefe388c55a7562ba38493876c1df14055a37..6ccddb0769850870c5d48050d3dda865bbb77383 100644 (file)
@@ -210,7 +210,7 @@ parse_ike_proposal() {
        export -n "$var=$crypto"
 }
 
-config_conn() {
+config_child() {
        # Generic ipsec conn section shared by tunnel and transport
        local config_name="$1"
        local mode="$2"
@@ -322,14 +322,14 @@ config_conn() {
 }
 
 config_tunnel() {
-       config_conn "$1" "tunnel"
+       config_child "$1" "tunnel"
 }
 
 config_transport() {
-       config_conn "$1" "transport"
+       config_child "$1" "transport"
 }
 
-config_remote() {
+config_connection() {
        local config_name="$1"
 
        local enabled
@@ -574,7 +574,7 @@ prepare_env() {
 
        config_load ipsec
        config_foreach config_ipsec ipsec
-       config_foreach config_remote remote
+       config_foreach config_connection remote
 
        do_postamble
 }