rp-pppoe: Fixed compilation with glibc 6056/head
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Wed, 23 May 2018 17:24:35 +0000 (14:24 -0300)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Wed, 23 May 2018 17:24:35 +0000 (14:24 -0300)
Do not inlcude <netinet/in.h> when using glibc to avoid various
redefinitions.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
net/rp-pppoe/Makefile
net/rp-pppoe/patches/140-glibc-avoid-include-linux_in.h.patch [new file with mode: 0644]

index 49a2c742a39dcc0c1e0496f3bb7f560588eb73f1..3d6726b40a466081b41dc3debfa72c758551ba8a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-pppoe
 PKG_VERSION:=3.12
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_MAINTAINER:=Daniel Dickinson <lede@cshore.thecshore.com>
 PKG_LICENSE:=LGPL-2.0+
 
diff --git a/net/rp-pppoe/patches/140-glibc-avoid-include-linux_in.h.patch b/net/rp-pppoe/patches/140-glibc-avoid-include-linux_in.h.patch
new file mode 100644 (file)
index 0000000..0a766f9
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/src/pppoe.h
++++ b/src/pppoe.h
+@@ -131,7 +131,9 @@ typedef unsigned long UINT32_t;
+ #include <linux/if_ether.h>
+ #endif
++#ifndef __GLIBC__
+ #include <netinet/in.h>
++#endif
+ #ifdef HAVE_NETINET_IF_ETHER_H
+ #include <sys/types.h>