syncthing: add runtime test
authorPaul Spooren <mail@aparcar.org>
Wed, 9 Sep 2020 20:59:50 +0000 (10:59 -1000)
committerPaul Spooren <mail@aparcar.org>
Wed, 16 Sep 2020 20:40:16 +0000 (10:40 -1000)
Run trivial check if the compiled binary works on the architecture.

Signed-off-by: Paul Spooren <mail@aparcar.org>
utils/syncthing/Makefile
utils/syncthing/test.sh [new file with mode: 0644]

index 18ae79d7d4209e4d45f9fd6a4df9142d836b039a..05c56c4d79adcdf741bbac6f1ada6fd63ed6d18e 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=syncthing
 PKG_VERSION:=1.9.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=syncthing-source-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/syncthing/syncthing/releases/download/v$(PKG_VERSION)
diff --git a/utils/syncthing/test.sh b/utils/syncthing/test.sh
new file mode 100644 (file)
index 0000000..5933bca
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+syncthing --version | grep "${2%%-*}"