remove msdos from vfat module, add ext2, ext3, xfs, hfsplus
authorFelix Fietkau <nbd@openwrt.org>
Sun, 10 Apr 2005 21:24:46 +0000 (21:24 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 10 Apr 2005 21:24:46 +0000 (21:24 +0000)
SVN-Revision: 615

openwrt/package/linux/Config.in
openwrt/package/linux/Makefile
openwrt/package/linux/control/kmod-ext2.control [new file with mode: 0644]
openwrt/package/linux/control/kmod-ext3.control [new file with mode: 0644]
openwrt/package/linux/control/kmod-hfsplus.control [new file with mode: 0644]
openwrt/package/linux/control/kmod-xfs.control [new file with mode: 0644]
openwrt/package/linux/linux.config

index b848572914980355bf766308d81abb6fb6e557f2..2ab006c8b85182331cc4cd2b8e631c38b2fcf3af 100644 (file)
@@ -97,6 +97,30 @@ config BR2_PACKAGE_KMOD_VFAT
          Kernel modules for VFAT filesystem support
          useful for usb mass storage devices
 
+config BR2_PACKAGE_KMOD_EXT2
+       tristate "EXT2 filesystem support"
+       default m
+       help
+         Kernel modules for EXT2 filesystem support
+
+config BR2_PACKAGE_KMOD_EXT3
+       tristate "EXT3 filesystem support"
+       default m
+       help
+         Kernel modules for EXT3 filesystem support
+
+config BR2_PACKAGE_KMOD_XFS
+       tristate "XFS filesystem support"
+       default m
+       help
+         Kernel modules for XFS filesystem support
+
+config BR2_PACKAGE_KMOD_HFSPLUS
+       tristate "HFS+ filesystem support"
+       default m
+       help
+         Kernel modules for HFS+ filesystem support
+
 config BR2_PACKAGE_KMOD_LP
        tristate "parallel port and lp support"
        default m
index 3f730355b953f7ef90d3683a1edc48719f66b3cb..fdd7e8d7699fef73dc965083234ab45bb198568d 100644 (file)
@@ -92,10 +92,22 @@ $(eval $(call KMOD_template,LP,lp,\
        $(MODULES_DIR)/kernel/drivers/parport/parport_splink.o \
        $(MODULES_DIR)/kernel/drivers/char/lp.o \
 ,CONFIG_PARPORT))
+$(eval $(call KMOD_template,EXT2,ext2,\
+       $(MODULES_DIR)/kernel/fs/ext2/*.o \
+,CONFIG_EXT2_FS))
+$(eval $(call KMOD_template,EXT3,ext3,\
+       $(MODULES_DIR)/kernel/fs/ext3/*.o \
+       $(MODULES_DIR)/kernel/fs/jbd/*.o \
+,CONFIG_EXT3_FS))
+$(eval $(call KMOD_template,XFS,xfs,\
+       $(MODULES_DIR)/kernel/fs/xfs/*.o \
+,CONFIG_XFS_FS))
+$(eval $(call KMOD_template,HFSPLUS,hfsplus,\
+       $(MODULES_DIR)/kernel/fs/hfsplus/*.o \
+,CONFIG_HFSPLUS_FS))
 $(eval $(call KMOD_template,VFAT,vfat,\
        $(MODULES_DIR)/kernel/fs/vfat/vfat.o \
        $(MODULES_DIR)/kernel/fs/fat/fat.o \
-       $(MODULES_DIR)/kernel/fs/msdos/msdos.o \
 ,CONFIG_VFAT_FS))
 $(eval $(call KMOD_template,CRYPTO,crypto,\
        $(MODULES_DIR)/kernel/crypto/*.o \
diff --git a/openwrt/package/linux/control/kmod-ext2.control b/openwrt/package/linux/control/kmod-ext2.control
new file mode 100644 (file)
index 0000000..546dfcb
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-ext2
+Priority: optional
+Section: sys
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Kernel modules for EXT2 filesystem support
diff --git a/openwrt/package/linux/control/kmod-ext3.control b/openwrt/package/linux/control/kmod-ext3.control
new file mode 100644 (file)
index 0000000..1340d58
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-ext3
+Priority: optional
+Section: sys
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Kernel modules for EXT3 filesystem support
diff --git a/openwrt/package/linux/control/kmod-hfsplus.control b/openwrt/package/linux/control/kmod-hfsplus.control
new file mode 100644 (file)
index 0000000..bb72a5f
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-hfsplus
+Priority: optional
+Section: sys
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Kernel modules for HFS+ filesystem support
diff --git a/openwrt/package/linux/control/kmod-xfs.control b/openwrt/package/linux/control/kmod-xfs.control
new file mode 100644 (file)
index 0000000..494e94c
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-xfs
+Priority: optional
+Section: sys
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Kernel modules for XFS filesystem support
index d4074ee903861ab0f13268683ac9f632f3db4414..7534ece882c996c04673e79ff9df4295a3b12a28 100644 (file)
@@ -876,15 +876,15 @@ CONFIG_SOFT_WATCHDOG=y
 # CONFIG_ADFS_FS_RW is not set
 # CONFIG_AFFS_FS is not set
 # CONFIG_HFS_FS is not set
-# CONFIG_HFSPLUS_FS is not set
+CONFIG_HFSPLUS_FS=m
 # CONFIG_BEFS_FS is not set
 # CONFIG_BEFS_DEBUG is not set
 # CONFIG_BFS_FS is not set
-# CONFIG_EXT3_FS is not set
-# CONFIG_JBD is not set
+CONFIG_EXT3_FS=m
+CONFIG_JBD=m
 # CONFIG_JBD_DEBUG is not set
 CONFIG_FAT_FS=m
-CONFIG_MSDOS_FS=m
+# CONFIG_MSDOS_FS is not set
 # CONFIG_UMSDOS_FS is not set
 CONFIG_VFAT_FS=m
 # CONFIG_EFS_FS is not set
@@ -925,7 +925,7 @@ CONFIG_EXT2_FS=m
 # CONFIG_UDF_RW is not set
 # CONFIG_UFS_FS is not set
 # CONFIG_UFS_FS_WRITE is not set
-# CONFIG_XFS_FS is not set
+CONFIG_XFS_FS=m
 # CONFIG_XFS_QUOTA is not set
 # CONFIG_XFS_RT is not set
 # CONFIG_XFS_TRACE is not set