cryptodev-linux: fix aria 2 spam message 4161/head
authorAnsuel Smith <ansuelsmth@gmail.com>
Sat, 18 Mar 2017 11:08:32 +0000 (12:08 +0100)
committerAnsuel Smith <ansuelsmth@gmail.com>
Sun, 19 Mar 2017 11:06:28 +0000 (12:06 +0100)
cryptodev log by default unecessary debug message
With some app (like aria2) the syslog get spammed with lots of this message
 cryptodev: aria2c[3231] (adjust_sg_array:106): reallocating from 32 to 512 pages

With this we disable logging of debug message as they are just for info purpose and they are not error at all.

Signed-off-by: Ansuel Smith ansuelsmth@gmail.com
utils/cryptodev-linux/Makefile
utils/cryptodev-linux/files/cryptodev.modules

index 45839015cc6df01b939562cfd2ac8af8ee51aa00..adc1ebb790e2e693f2dc4ca5984dfb6e75b4e273 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=cryptodev-linux
 PKG_VERSION:=1.8.git-2017-02-09
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -20,6 +20,8 @@ PKG_MIRROR_HASH:=627ce96e3ba66ca9c8e14f5d80193061fbe9d45cd8d4b69a1bf4dd5a2d50eed
 PKG_SOURCE_URL:=https://github.com/cryptodev-linux/cryptodev-linux.git
 PKG_SOURCE_VERSION:=6818263667ca488f9b1c86e36ea624c4ea1c309f
 
+PKG_MAINTAINER:=Ansuel Smith ansuelsmth@gmail.com
+
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
@@ -70,7 +72,7 @@ endef
 
 define KernelPackage/cryptodev/install
        $(INSTALL_DIR) $(1)/etc/modules.d
-       $(INSTALL_DATA) ./files/cryptodev.modules $(1)/etc/modules.d/80-cryptodev
+       $(INSTALL_DATA) ./files/cryptodev.modules $(1)/etc/modules.d/50-cryptodev
        $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
        $(INSTALL_DIR) $(1)/usr/sbin
 endef
index fb39fcd6dc3a6ee206bf9b311746425cc9caa219..48194e27c80a1d1c0f6b9396a23497d7a125cbf0 100644 (file)
@@ -1 +1 @@
-cryptodev
+cryptodev cryptodev_verbosity=-1