[package] uhttpd: fix segfault triggered by Basic Auth checking
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 25 Aug 2010 21:38:48 +0000 (21:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 25 Aug 2010 21:38:48 +0000 (21:38 +0000)
SVN-Revision: 22805

package/uhttpd/Makefile
package/uhttpd/src/uhttpd-utils.c

index 1227174536a50ab3e3f95e1007b70a409b1c74b0..086c294580f1672509fcd3201576c082ac647a8f 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=16
+PKG_RELEASE:=17
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_BUILD_DEPENDS := libcyassl liblua
index 8a06c930af6d99c748b33f1e30e149904acd1448..3821eb54cb18df8328d79d583d80d3a0bd7dc4bd 100644 (file)
@@ -728,8 +728,6 @@ int uh_auth_check(
                                        req->realm = realm;
                                        break;
                                }
-
-                               realm = NULL;
                        }
 
                        /* found a realm matching the username */