icu: Revert "icu: Deactivate uClibc"
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Tue, 8 Oct 2019 21:10:49 +0000 (18:10 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Tue, 8 Oct 2019 21:10:49 +0000 (18:10 -0300)
This reverts commit db424ede2f079f2bf73634d30ec3c59a8a782118.
It is causing recursive dependencies.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
libs/icu/Makefile

index 7927b55efd72e76d126c8dbc8fa25ee746543b34..ba42cfff33a5f8f4c9c7608d2bf140af065fb08e 100644 (file)
@@ -11,7 +11,7 @@ PKG_NAME:=icu4c
 MAJOR_VERSION:=65
 MINOR_VERSION:=1
 PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
 PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
@@ -40,7 +40,7 @@ define Package/icu
   CATEGORY:=Libraries
   TITLE:=International Components for Unicode
   URL:=http://icu-project.org
-  DEPENDS:=+libstdcpp +libpthread @!USE_UCLIBC
+  DEPENDS:=+libstdcpp +libpthread
 endef
 
 define Package/icu/description