rsync: drop option for included zlib
authorIan Leonard <antonlacon@gmail.com>
Sun, 26 Jul 2020 07:01:27 +0000 (00:01 -0700)
committerIan Leonard <antonlacon@gmail.com>
Sat, 3 Oct 2020 03:53:50 +0000 (20:53 -0700)
Signed-off-by: Ian Leonard <antonlacon@gmail.com>
net/rsync/Config.in
net/rsync/Makefile

index ea1c594510004a29df6bf773510d5371e29b3418..5c297f400a418eb05053f12107e7bb34e75219d2 100644 (file)
@@ -12,16 +12,4 @@ if PACKAGE_rsync
                default y if USE_FS_ACL_ATTR
                default n
 
-       config RSYNC_zlib
-               bool
-               prompt "Enable system zlib"
-               help 
-                       Use the system's zlib library instead of rsync's internal copy. Enabling
-                       this may create compatibility errors when using compression  with older
-                       clients, or those using the current default of the bundled zlib.
-
-                       rsync's upstream default is to use their bundled zlib. OpenWrt uses the
-                       system zlib for space reasons. The system zlib will eventually become 
-                       default for upstream as well.
-               default y
 endif
index ca8205ea7f6da68cd6893ac1292388d9cbcee896..6452def0ed46486fc92a1ffe7282473c7134da6a 100644 (file)
@@ -30,7 +30,7 @@ define Package/rsync
   CATEGORY:=Network
   SUBMENU:=File Transfer
   TITLE:=Fast remote file copy program (like rcp)
-  DEPENDS:=+libpopt +RSYNC_xattr:libattr +RSYNC_acl:libacl +RSYNC_zlib:zlib
+  DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl
   URL:=https://rsync.samba.org/
   MENU:=1
 endef
@@ -43,6 +43,7 @@ TARGET_CFLAGS += $(if $(CONFIG_IPV6),-DINET6,)
 
 CONFIGURE_ARGS += \
        --without-included-popt \
+       --without-included-zlib \
        --disable-debug \
        --disable-asm \
        --disable-iconv \
@@ -56,7 +57,6 @@ CONFIGURE_ARGS += \
        --disable-zstd \
        --$(if $(CONFIG_RSYNC_xattr),en,dis)able-xattr-support \
        --$(if $(CONFIG_RSYNC_acl),en,dis)able-acl-support \
-       --with$(if $(CONFIG_RSYNC_zlib),,out)-included-zlib \
        $(if $(CONFIG_IPV6),,--disable-ipv6)
 
 define Package/rsyncd