openvswitch: Change dependency from append to definition
authorMatthew Hagan <mathagan@fb.com>
Wed, 15 Dec 2021 15:27:37 +0000 (15:27 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 16 Dec 2021 05:25:37 +0000 (13:25 +0800)
ovs_libovsdb_depends and ovs_libofproto_depends append the libatomic
dependency. However in these cases these variables were not previously
defined and thus a reader may search the Makefile for the definition.
Therefore change the operator to explicitly define these dependency
variables, rather than append. In addition add a space after operator to
improve readability and conform to other dependency definitions in the
Makefile.

Signed-off-by: Matthew Hagan <mathagan@fb.com>
net/openvswitch/Makefile

index 8b0a0c82876749111cb507628049665428ec7832..f9c212da15ae1a38bf4e02e6ec1b6db585885114 100644 (file)
@@ -163,14 +163,14 @@ $(eval $(call OvsPackageTemplate,libopenvswitch))
 
 ovs_libofproto_title:=Open vSwitch (libofproto.so libsflow.so)
 ovs_libofproto_hidden:=1
-ovs_libofproto_depends+=+libatomic
+ovs_libofproto_depends:= +libatomic
 ovs_libofproto_files:=usr/lib/libofproto*.so* usr/lib/libsflow*.so*
 $(eval $(call OvsPackageTemplate,libofproto))
 
 
 ovs_libovsdb_title:=Open vSwitch (libovsdb.so)
 ovs_libovsdb_hidden:=1
-ovs_libovsdb_depends+=+libatomic
+ovs_libovsdb_depends:= +libatomic
 ovs_libovsdb_files:=usr/lib/libovsdb*.so*
 $(eval $(call OvsPackageTemplate,libovsdb))