lpeg: Fix build with external toolchains
authorFlorian Fainelli <f.fainelli@gmail.com>
Tue, 6 Jun 2017 00:44:27 +0000 (17:44 -0700)
committerFlorian Fainelli <f.fainelli@gmail.com>
Tue, 6 Jun 2017 00:44:27 +0000 (17:44 -0700)
We are not properly passing down TARGET_CFLAGS and TARGET_CPPFLAGS and
this can be noticed with external toolchains with the following build
error:

mipsel-linux-gnu-gcc -Wall -Wextra -pedantic -Waggregate-return
-Wcast-align -Wcast-qual -Wdisabled-optimization -Wpointer-arith
-Wshadow -Wsign-compare -Wundef -Wwrite-strings -Wbad-function-cast
-Wdeclaration-after-statement -Wmissing-prototypes -Wnested-externs
-Wstrict-prototypes  -O2 -std=c99 -I../lua/ -fPIC   -c -o lpvm.o lpvm.c
lpvm.c:10:17: fatal error: lua.h: No such file or directory
 #include "lua.h"
                 ^
compilation terminated.
make[4]: *** [lpvm.o] Error 1

Re-use COPT to pass our TARGET_CFLAGS and TARGET_CPPFLAGS

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
lang/lpeg/Makefile

index ee8a4ef1fedd0ff77962ff3a802305b57a2d276c..35f5aa673bb31f3c024875efe5288ac36046b42a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lpeg
 PKG_VERSION:=0.12.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
 PKG_LICENSE:=MIT
 
@@ -38,7 +38,8 @@ define Build/Configure
 endef
 
 # add make variable overrides here
-MAKE_FLAGS +=
+MAKE_FLAGS += \
+       COPT="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -O2"
 
 define Package/lpeg/install
        $(INSTALL_DIR) $(1)/usr/lib/lua