pcre: Fix compile of libpcrecpp 8373/head
authorJan Kardell <jan.kardell@telliq.com>
Sun, 10 Mar 2019 16:30:39 +0000 (17:30 +0100)
committerJan Kardell <jan.kardell@telliq.com>
Sun, 10 Mar 2019 17:00:20 +0000 (18:00 +0100)
If the cpp lib is added after pcre is first compiled, pcre will
not be reconfigured and the build will fail.
Fix this by always building the cpp parts.

Signed-off-by: Jan Kardell <jan.kardell@telliq.com>
libs/pcre/Makefile

index 3208aa7aca58598e63ae258d80018193f4fc2b43..945819e4cbc1b4ad3816108774586701ff3fd11b 100644 (file)
@@ -55,12 +55,8 @@ CONFIGURE_ARGS += \
        --enable-unicode-properties \
        --enable-pcre16 \
        --with-match-limit-recursion=16000 \
+       --enable-cpp
 
-ifneq ($(CONFIG_PACKAGE_libpcrecpp),)
-  CONFIGURE_ARGS+= --enable-cpp
-else
-  CONFIGURE_ARGS+= --disable-cpp
-endif
 
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)"