perf: Depend on libbfd and libopcodes when enabled
authorFlorian Fainelli <f.fainelli@gmail.com>
Sat, 8 Jan 2022 16:45:29 +0000 (08:45 -0800)
committerFlorian Fainelli <f.fainelli@gmail.com>
Fri, 28 Jan 2022 04:16:57 +0000 (20:16 -0800)
bpftool will enabled libbfd and libopcodes which gets picked up by perf
as libraries to link against. Add those missing dependencies when either
of these packages are enabled.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/devel/perf/Makefile

index bbf3aaf9ceac94dee12dfe778eadd850b714728f..eacdd0e2e56f02309bf2aac2844c0a5010397dc7 100644 (file)
@@ -27,7 +27,8 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/perf
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:= +libelf +libdw +PACKAGE_libunwind:libunwind +libpthread +librt +objdump @!IN_SDK @!TARGET_arc770 @KERNEL_PERF_EVENTS
+  DEPENDS:= +libelf +libdw +PACKAGE_libunwind:libunwind +libpthread +librt +objdump @!IN_SDK @!TARGET_arc770 @KERNEL_PERF_EVENTS \
+           +PACKAGE_libbfd:libbfd +PACKAGE_libopcodes:libopcodes
   TITLE:=Linux performance monitoring tool
   VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
   URL:=http://www.kernel.org