vips: update to 8.12.1
authorW. Michael Petullo <mike@flyn.org>
Sun, 12 Dec 2021 20:31:17 +0000 (14:31 -0600)
committerNick Hainke <vincent@systemli.org>
Mon, 13 Dec 2021 21:44:43 +0000 (22:44 +0100)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
libs/vips/Makefile
libs/vips/patches/001-no_introspection.patch [deleted file]
libs/vips/patches/010-reproducible-build.patch

index a8eb4c7a49a4153a70de2cdf3bab124f11129706..2f79492105e026d49080e6d85d67b2b72a3c16ce 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vips
-PKG_VERSION:=8.10.6
+PKG_VERSION:=8.12.1
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
-PKG_HASH:=2468088d958e0e2de1be2991ff8940bf45664a826c0dad12342e1804e2805a6e
+PKG_HASH:=474d8439244cd26c504812fd623259f806c32553b38d2a54798c9766135f5a5c
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 PKG_LICENSE:=LGPL-2.1-or-later
diff --git a/libs/vips/patches/001-no_introspection.patch b/libs/vips/patches/001-no_introspection.patch
deleted file mode 100644 (file)
index f66fbaf..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -53,9 +53,6 @@ AC_SUBST(LIBRARY_CURRENT)
- AC_SUBST(LIBRARY_REVISION)
- AC_SUBST(LIBRARY_AGE)
--# init introspection support
--GOBJECT_INTROSPECTION_CHECK([1.30.0])
--
- # remove the '(disabled, use --enable-introspection to enable)'
- # suffix from the found_introspection variable
- if test "x$found_introspection" != x"yes"; then
---- a/libvips/Makefile.am
-+++ b/libvips/Makefile.am
-@@ -67,56 +67,3 @@ install-exec-hook:
-       echo "#define VIPS_SONAME \"$$dlname\"" >> soname.h && \
-       cp soname.h $(DESTDIR)$(pkgincludedir) && \
-       rm soname.h
--
---include $(INTROSPECTION_MAKEFILE)
--INTROSPECTION_GIRS =
--INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir)
--INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
--
--if HAVE_INTROSPECTION
--
--AM_CPPFLAGS = \
--            -I${top_srcdir}/libvips/include \
--            @VIPS_CFLAGS@ \
--            @VIPS_INCLUDES@ \
--            @INTROSPECTION_CFLAGS@ 
--AM_LDFLAGS = \
--           @INTROSPECTION_LIBS@ \
--           @LDFLAGS@ 
--LDADD = @INTROSPECTION_LIBS@ @VIPS_CFLAGS@ libvips.la @VIPS_LIBS@ 
--
--noinst_PROGRAMS = \
--      introspect$(EXEEXT)
--introspect_SOURCES = \
--      introspect.c
--
--# we can't get the _SOURCES lists from the subdirs directly, we get passed it
--# by configure instead
--introspection_sources = @vips_introspection_sources@
--
--# we make the vips8 API
--Vips-8.0.gir: introspect$(EXEEXT)
--Vips_8_0_gir_INCLUDES = GObject-2.0
--Vips_8_0_gir_CFLAGS = $(INCLUDES) -I${top_srcdir}/libvips/include
--Vips_8_0_gir_LIBS = libvips.la
--Vips_8_0_gir_FILES = $(introspection_sources)
--INTROSPECTION_GIRS += Vips-8.0.gir
--
--# don't use
--#   --warn-all --verbose
--# too annoying
--Vips_8_0_gir_SCANNERFLAGS = \
--      --program=./introspect$(EXEEXT) \
--      --identifier-prefix=Vips \
--      --identifier-prefix=vips \
--      --symbol-prefix=vips \
--      --c-include=vips/vips.h
--
--girdir = $(datadir)/gir-1.0
--gir_DATA = $(INTROSPECTION_GIRS)
--
--typelibdir = $(libdir)/girepository-1.0
--typelib_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
--
--CLEANFILES += $(gir_DATA) $(typelib_DATA)
--endif
index 883db7ddd75520b250bef1a08863d6ff9dd22906..c6e990212dcfd2292c36f51162b45cf80ca0edc7 100644 (file)
@@ -4,12 +4,12 @@
  VIPS_MINOR_VERSION=vips_minor_version()
  VIPS_MICRO_VERSION=vips_micro_version()
  VIPS_VERSION=vips_version()
--VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r $srcdir/ChangeLog`
+-VIPS_VERSION_STRING="$VIPS_VERSION-$(date -u -r $srcdir/ChangeLog)"
 +if test "x$SOURCE_DATE_EPOCH" = "x"; then
 +  VIPS_VERSION_STRING=$VIPS_VERSION-`date -u -r ChangeLog`
 +else
 +  VIPS_VERSION_STRING=$VIPS_VERSION-`LC_ALL=C date --utc --date="@$SOURCE_DATE_EPOCH"`
 +fi
  
- # libtool library versioning ... not user-visible (except as part of the
- # library file name) and does not correspond to major/minor/micro above
+ # packages add to these as we find them
+ VIPS_CFLAGS=""