audit: remove host build
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 11 May 2022 22:37:12 +0000 (19:37 -0300)
committerRosen Penev <rosenp@gmail.com>
Fri, 20 May 2022 19:18:31 +0000 (12:18 -0700)
The audit package in the packages feed share the same sources as the
libaudit package in the base repo.  libaudit performs a host build, used
only by libsemanage in base.

There is no package depending on 'audit/host', so we can remove it to
avoid possible confusion.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
utils/audit/Makefile

index 8fcc744a20c845491692401d7e4609437845aa6c..80f3416c8cc9452b731798e2db7688ad76f59b29 100644 (file)
@@ -24,7 +24,6 @@ PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-packages/$(PKG_NAME)-$(PKG_VERSION)
 PKG_USE_MIPS16:=0
 
 include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/host-build.mk
 
 define Package/audit/Default
   TITLE:=Audit Daemon
@@ -139,7 +138,6 @@ define Package/audit/install
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/auditd $(1)/usr/sbin/
 endef
 
-$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libauparse))
 $(eval $(call BuildPackage,audit-utils))
 $(eval $(call BuildPackage,audit))