node-hid: fix issues with node 8.11.3
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Wed, 8 Aug 2018 15:06:56 +0000 (12:06 -0300)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Wed, 8 Aug 2018 17:42:03 +0000 (14:42 -0300)
Get node version from node executable instead of keeping it hardcoded to
the Makefile.

Current version of npm install installs a link to the build directory.
The workaround is to use npm pack to make a tarball and install from
that.
npm also adds useless metadata to package.json exposing
PKG_BUILD_DIR, so it needs to be stripped.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
lang/node-hid/Makefile

index afcda10279dba318d34436397196860c0cf437fb..e833f1c687b12e6325f638d4e3704268edfe5bb0 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NPM_NAME:=hid
 PKG_NAME:=node-$(PKG_NPM_NAME)
 PKG_VERSION:=0.7.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/node-hid/node-hid.git
@@ -19,8 +19,8 @@ PKG_SOURCE_VERSION:=v0.7.2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MIRROR_HASH:=ede801a26a23290ab76d64ab636c3c3e2788030bb830af7006d37444c2a7b2c4
 
-PKG_BUILD_DEPENDS:=node/host libudev-fbsd
-PKG_NODE_VERSION:=8.10.0
+PKG_BUILD_DEPENDS:=node/host
+PKG_NODE_VERSION:=`$(STAGING_DIR_HOSTPKG)/bin/node --version`
 
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 PKG_LICENSE:=Custom
@@ -50,15 +50,24 @@ define Build/Compile
        $(MAKE_VARS) \
        $(MAKE_FLAGS) \
        npm_config_arch=$(CONFIG_ARCH) \
-       npm_config_nodedir=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/ \
-       npm_config_cache=$(BUILD_DIR)/node-v$(PKG_NODE_VERSION)/npm-cache \
+       npm_config_nodedir=$(BUILD_DIR)/node-$(PKG_NODE_VERSION)/ \
+       npm_config_cache=$(BUILD_DIR)/node-$(PKG_NODE_VERSION)/npm-cache \
        PREFIX="$(PKG_INSTALL_DIR)/usr/" \
        npm install --build-from-source --target_arch=$(CPU) -g $(PKG_BUILD_DIR)
 endef
 
 define Package/node-hid/install
        mkdir -p $(1)/usr/lib/node/node-hid/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/ $(1)/usr/lib/node/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/. $(1)/usr/lib/node/
+       $(RM) -rf $(1)/usr/lib/node/node-hid/patches \
+                 $(1)/usr/lib/node/node-hid/.p* \
+                 $(1)/usr/lib/node/node-hid/.quilt* \
+                 $(1)/usr/lib/node/node-hid/.built* \
+                 $(1)/usr/lib/node/node-hid/.config*
+       # Strip PKG_BUILD_DIR from useless metadata inserted by npm install
+       # https://github.com/npm/npm/issues/10393
+       # https://github.com/npm/npm/issues/12110
+       find $(1)/usr/lib/node -name package.json -exec sed -i -e 's,$(PKG_BUILD_DIR),,g' {} +
 endef
 
 $(eval $(call BuildPackage,node-hid))