softflowd: fix compilation with newer musl 11691/head
authorRosen Penev <rosenp@gmail.com>
Sun, 29 Mar 2020 00:00:32 +0000 (17:00 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 29 Mar 2020 03:40:52 +0000 (20:40 -0700)
__uid_t is a glibc extension. Switch to standard uid_t.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/softflowd/Makefile
net/softflowd/patches/020-uid.patch [new file with mode: 0644]

index cf379ce7080f6ae7f70bd7bfa04e357c5ba6a701..3e966e4956178e4df104b4a19882594666eca358 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=softflowd
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/irino/softflowd/tar.gz/softflowd-$(PKG_VERSION)?
diff --git a/net/softflowd/patches/020-uid.patch b/net/softflowd/patches/020-uid.patch
new file mode 100644 (file)
index 0000000..fe2ea7c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/common.h
++++ b/common.h
+@@ -179,7 +179,7 @@ struct ip6_ext {
+ /* following lines are copy from unistd.h in Linux for avoidance warnings in compilation */
+ #if defined(HAVE_SETRESGID) && !defined(_GNU_SOURCE)
+-extern int setresgid (__uid_t __ruid, __uid_t __euid, __uid_t __suid);
++extern int setresgid (uid_t __ruid, uid_t __euid, uid_t __suid);
+ #endif
+ #if defined(HAVE_SETRESUID) && !defined(_GNU_SOURCE)
+ extern int setresuid (__uid_t __ruid, __uid_t __euid, __uid_t __suid);