add missing codepages, add syslog support and use it by default
authorNicolas Thill <nico@openwrt.org>
Thu, 29 Sep 2005 07:04:02 +0000 (07:04 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 29 Sep 2005 07:04:02 +0000 (07:04 +0000)
SVN-Revision: 1996

openwrt/package/samba/Makefile
openwrt/package/samba/files/samba.init
openwrt/package/samba/files/smb.conf

index 7a083b3a464084fff0b706c4907da84f3ed60e74..566e604a035dc23d81a21d06c393b02d6950ffaf 100644 (file)
@@ -119,6 +119,7 @@ $(PKG_BUILD_DIR)/.built:
                        $(DISABLE_NLS) \
                        --with-lockdir=/var/run/samba \
                        --with-privatedir=/etc/samba \
+                       --with-syslog \
        );
        $(MAKE) -C $(PKG_BUILD_DIR)/source \
                $(TARGET_CONFIGURE_OPTS) \
@@ -160,6 +161,7 @@ $(IPKG_SAMBA):
        install -m0755 $(PKG_BUILD_DIR)/source/bin/smbd.shared $(IDIR_SAMBA)/usr/sbin/smbd
        install -d -m0755 $(IDIR_SAMBA)/usr/share/samba
        install -m0644 $(PKG_INSTALL_DIR)/usr/share/samba/codepage.{437,850} $(IDIR_SAMBA)/usr/share/samba/
+       install -m0644 $(PKG_INSTALL_DIR)/usr/share/samba/unicode_map.{437,850} $(IDIR_SAMBA)/usr/share/samba/
        $(RSTRIP) $(IDIR_SAMBA)
        $(IPKG_BUILD) $(IDIR_SAMBA) $(PACKAGE_DIR)
 
index 43ab372caf728ec8104d614b19a3f9598d5e00d8..c3c600ae3eb6ab0ed7f5c8682c223e77df47f69a 100644 (file)
@@ -1,7 +1,6 @@
 #!/bin/sh
 
 DEFAULT=/etc/default/samba
-LOG_D=/var/log/samba
 RUN_D=/var/run/samba
 NMBD_PID_F=$RUN_D/nmbd.pid
 SMBD_PID_F=$RUN_D/smbd.pid
@@ -9,7 +8,6 @@ SMBD_PID_F=$RUN_D/smbd.pid
 
 case $1 in
  start)
-  mkdir -p $LOG_D
   mkdir -p $RUN_D
   nmbd -D $NMBD_OPTIONS
   smbd -D $SMBD_OPTIONS
index 4c4cd1dab25baff664fd581e44b36c6e53fe8ab8..5a2f6ccaa902001c1157c075e256d290a406dcdf 100644 (file)
@@ -1,4 +1,6 @@
 [global]
+ syslog = 0
+ syslog only = yes
  workgroup = OpenWrt
  security = share
  guest account = nobody