strongswan: drop subshell when possible
authorPhilip Prindeville <philipp@redfish-solutions.com>
Tue, 13 Apr 2021 18:32:57 +0000 (12:32 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Tue, 13 Apr 2021 18:45:57 +0000 (12:45 -0600)
A subshell caused by $(...) can't persistently modify globals as a
side-effect.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/strongswan/Makefile
net/strongswan/files/swanctl.init

index 25249c81e81994adeca40a42022331b436994355..d58afad99871d94871e0183ccbcb8915f583faa1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
index 21fc7e8ec5e066884344128467f9fae87d1fc6ab..344518e3c875d79620042fb4d58b57df7375f842 100644 (file)
@@ -160,11 +160,13 @@ add_esp_proposal() {
 
 parse_esp_proposal() {
        local conf="$1"
+       local var="$2"
+
        local crypto=""
 
        config_list_foreach "$conf" crypto_proposal add_esp_proposal
 
-       echo "$crypto"
+       export -n "$var=$crypto"
 }
 
 add_ike_proposal() {
@@ -190,11 +192,13 @@ add_ike_proposal() {
 
 parse_ike_proposal() {
        local conf="$1"
+       local var="$2"
+
        local crypto=""
 
        config_list_foreach "$conf" crypto_proposal add_ike_proposal
 
-       echo "$crypto"
+       export -n "$var=$crypto"
 }
 
 config_conn() {
@@ -228,7 +232,8 @@ config_conn() {
        config_get if_id "$1" if_id ""
        config_get rekeytime "$1" rekeytime ""
 
-       local esp_proposal="$(parse_esp_proposal "$1")"
+       local esp_proposal
+       parse_esp_proposal "$1" esp_proposal
 
        # translate from ipsec to swanctl
        case "$startaction" in
@@ -387,7 +392,8 @@ config_remote() {
                local_gateway=`ip -o route get $ipdest | awk '/ src / { gsub(/^.* src /,""); gsub(/ .*$/, ""); print $0}'`
        }
 
-       local ike_proposal="$(parse_ike_proposal "$1")"
+       local ike_proposal
+       parse_ike_proposal "$1" ike_proposal
 
        [ -n "$firewall" ] && warning "Firewall not supported"