armvirt/64: change it to cortex-a53 instead of generic
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Sun, 13 Dec 2020 14:02:36 +0000 (15:02 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 14 Dec 2020 21:38:10 +0000 (21:38 +0000)
Package architecture aarch64_generic [1] can be used just with three
devices. One is NanoPI R2S and then there are two development boards
from NXP. Let's change armvirt/64 to Cortex A53 (aarch64_cortex-a53)
[2]. It has wider support by multiple devices like NanoPI Neo Plus2/Core2,
ESPRESSObin, Pine64, and Raspberry Pi 2&3.

While looking at ARMvirt/32 it has set CPU_TYPE and CPU_SUBTYPE to be
arm_cortex-a15_neon-vfpv4 [3]. It has support to devices like
Linksys EA8500 v1, Linksys EA7500 v1, Netgear D7800, Netgear R7500 and so on.

Tested with:
qemu-system-aarch64 -m 1024 -smp 2 -cpu cortex-a57 -M virt -nographic \
-kernel openwrt-armvirt-64-Image-initramfs

Successfully compiled and booted.
Here goes the output:
root@OpenWrt:/# uname -a
Linux OpenWrt 5.4.82 #0 SMP Sun Dec 13 12:52:10 2020 aarch64 GNU/Linux
root@OpenWrt:/# cat /etc/openwrt_release
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='SNAPSHOT'
DISTRIB_REVISION='r15207-96fca0f807'
DISTRIB_TARGET='armvirt/64'
DISTRIB_ARCH='aarch64_cortex-a53'
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r15207-96fca0f807'
DISTRIB_TAINTS='no-all'

Also, change BOARDNAME to be the same as it is in armvirt/32.

[1] https://openwrt.org/docs/techref/instructionset/aarch64_generic
[2] https://openwrt.org/docs/techref/instructionset/aarch64_cortex-a53
[3] https://openwrt.org/docs/techref/instructionset/arm_cortex-a15_neon-vfpv4

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
target/linux/armvirt/64/target.mk

index 38d8fa13b6b14c7b6c6c4adea9b29f62cb6f6586..58adcc7d60238938b10c52d2b786df1e8a97b6d6 100644 (file)
@@ -1,8 +1,9 @@
 ARCH:=aarch64
 SUBTARGET:=64
-BOARDNAME:=ARMv8 multiplatform
+BOARDNAME:=QEMU ARMv8 Virtual Machine (cortex-a53)
+CPU_TYPE:=cortex-a53
 KERNELNAME:=Image
 
 define Target/Description
-       Build multi-platform images for the ARMv8 instruction set architecture
+  Build multi-platform images for the ARMv8 instruction set architecture
 endef