ath79: streamline image-generation for OCEDO boards
authorDavid Bauer <mail@david-bauer.net>
Wed, 4 Nov 2020 23:00:37 +0000 (00:00 +0100)
committerDavid Bauer <mail@david-bauer.net>
Wed, 4 Nov 2020 23:00:37 +0000 (00:00 +0100)
Use the default sysupgrade generation procedure provided
by the target. The previously generated images had the rootfs not
aligned to an eraseblock.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/image/generic.mk

index b6ec366eb0c2e551591058cd88627df83e51e932..1c2c805b2a6bc45c464d688859535f8e71ab8132 100644 (file)
@@ -1348,8 +1348,6 @@ define Device/ocedo_koala
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
   SUPPORTED_DEVICES += koala
   IMAGE_SIZE := 7424k
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
 endef
 TARGET_DEVICES += ocedo_koala
 
@@ -1358,8 +1356,6 @@ define Device/ocedo_raccoon
   DEVICE_VENDOR := Ocedo
   DEVICE_MODEL := Raccoon
   IMAGE_SIZE := 7424k
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
 endef
 TARGET_DEVICES += ocedo_raccoon
 
@@ -1369,8 +1365,6 @@ define Device/ocedo_ursus
   DEVICE_MODEL := Ursus
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 7424k
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
 endef
 TARGET_DEVICES += ocedo_ursus