Optimized caching behaviour, automatically flush caches in dev environment
authorSteven Barth <steven@midlink.org>
Mon, 15 Sep 2008 16:49:56 +0000 (16:49 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 15 Sep 2008 16:49:56 +0000 (16:49 +0000)
Makefile
libs/core/luasrc/ccache.lua
libs/sgi-cgi/htdocs/cgi-bin/luci
libs/web/root/etc/config/luci

index c90f11fc9d0bf4279b334b31df61485beb7f927d..acb6659df69ef67d14040d0bf53e87225c9288f0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,7 @@ hostcopy:
        for i in $(MODULES); do cp -a $$i/hostfiles/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        ln -s .$(LUCI_MODULEDIR) host/luci
+       rm -rf /tmp/luci-* || true
 
 hostenv: host ucidefaults
 
index 437d385256e915df4384f8b46b2c876d3f34dd2a..83e82d9fdc9488890812998212f02ca882982832 100644 (file)
@@ -32,7 +32,7 @@ function cache_ondemand(...)
 end
 
 function cache_enable(cachepath, mode)
-       cachepath = cachepath or "/tmp/.luciccache"
+       cachepath = cachepath or "/tmp/luci-modulecache"
        mode = mode or "r--r--r--"
 
        local loader = package.loaders[2]
index cd9bb59660e8112ba6ffea5aa2786cb5a1423ca5..529d1d0bc51c3d0fe4b1981da27d99dffa2084e4 100755 (executable)
@@ -1,5 +1,5 @@
 #!/usr/bin/lua
 require "luci.cacheloader"
 require "luci.sgi.cgi"
-luci.dispatcher.indexcache = "/tmp/.luciindex"
+luci.dispatcher.indexcache = "/tmp/luci-indexcache"
 luci.sgi.cgi.run()
\ No newline at end of file
index f78fbb02b9763ccfda5b7a41bb4dd3d9d2a907be..4e31f9d9bd21d764cad1e6dfa98b14bf50264176 100644 (file)
@@ -21,7 +21,7 @@ config extern flash_keep
 config internal languages
        
 config internal sauth
-       option sessionpath "/tmp/.lucisessions"
+       option sessionpath "/tmp/luci-sessions"
        option sessiontime 3600
        
 config internal ccache
@@ -29,6 +29,6 @@ config internal ccache
 
 config internal template
        option compiler_mode file
-       option compiledir "/tmp/.lucitplcache"
+       option compiledir "/tmp/luci-templatecache"
                
 config internal themes