libdrm: add option to build the nouveau and radeon driver 14953/head
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 28 Feb 2021 10:24:16 +0000 (11:24 +0100)
committerBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 1 Mar 2021 06:04:01 +0000 (07:04 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
libs/libdrm/Config.in
libs/libdrm/Makefile

index 32602c736ff63c03cfb00bdc5b1c487386ae455c..6199b704a86f4c22f75d6d92b4a81358e9a9e764 100644 (file)
@@ -8,4 +8,16 @@ config LIBDRM_INTEL
        help
                Installs the Intel driver.
 
+config LIBDRM_NOUVEAU
+       bool "Nouveau support"
+       default n
+       help
+               Installs the Nouveau driver.
+
+config LIBDRM_RADEON
+       bool "Radeon support"
+       default n
+       help
+               Installs the Radeon driver.
+
 endmenu
index 669b8956ce35e4354f559636d133d37ff8c3dcd9..206748878305c8cd99e2a4e29e18853095a5e533 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libdrm
 PKG_VERSION:=2.4.104
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://dri.freedesktop.org/libdrm
@@ -17,7 +17,9 @@ PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
 PKG_LICENSE:=BSD-3-Clause
 
 PKG_CONFIG_DEPENDS:= \
-       CONFIG_LIBDRM_INTEL
+       CONFIG_LIBDRM_INTEL \
+       CONFIG_LIBDRM_NOUVEAU \
+       CONFIG_LIBDRM_RADEON
 
 PKG_INSTALL:=1
 PKG_BUILD_DEPENDS:=meson/host
@@ -45,9 +47,9 @@ endef
 
 MESON_ARGS += \
        $(if $(CONFIG_LIBDRM_INTEL),-Dintel=true -Dlibkms=true,-Dintel=false -Dlibkms=false) \
-       -Dradeon=false \
+       -Dradeon=$(if $(CONFIG_LIBDRM_RADEON),true,false) \
        -Damdgpu=false \
-       -Dnouveau=false \
+       -Dnouveau=$(if $(CONFIG_LIBDRM_NOUVEAU),true,false) \
        -Dvmwgfx=false \
        -Domap=false \
        -Dexynos=false \