luci-app-sshtunnel: servers: ProxyCommand option
authorSergey Ponomarev <stokito@gmail.com>
Thu, 28 Dec 2023 17:39:51 +0000 (19:39 +0200)
committerPaul Donald <itsascambutmailmeanyway@gmail.com>
Thu, 28 Dec 2023 17:46:49 +0000 (17:46 +0000)
Signed-off-by: Sergey Ponomarev <stokito@gmail.com>
applications/luci-app-sshtunnel/Makefile
applications/luci-app-sshtunnel/htdocs/luci-static/resources/view/sshtunnel/ssh_servers.js

index 4298b6107ff1545a7a744bf28410cc17d3a9cbc7..f686ff103fa45ed89c40aa5aa0d7a490f4dcb556 100644 (file)
@@ -7,7 +7,7 @@ LUCI_TITLE:=LuCI support for SSH Tunnels (sshtunnel package)
 
 PKG_MAINTAINER:=Sergey Ponomarev <stokito@gmail.com>
 LUCI_DEPENDS:=+luci-base +sshtunnel
-PKG_VERSION:=1.0.0
+PKG_VERSION:=1.1.0
 PKG_RELEASE:=1
 
 include ../../luci.mk
index 88c3692728b5e3c8464c08fc45f49d458967923e..7a45ddc32b99a64d363e1512004c97842f58e190 100644 (file)
@@ -127,6 +127,14 @@ return view.extend({
                o.default = 'accept-new';
                o.modalonly = true;
 
+               o = s.taboption('advanced', form.Value, 'ProxyCommand', _('Proxy tunnel command'),
+                       _('The command to use to connect to the server.') + '<br />' +
+                       _('For example, the following command would connect via an HTTP proxy:') + '<br />' +
+                       '<code>ncat --proxy-type http --proxy-auth alice:secret --proxy 192.168.1.2:8080 %h %p</code>' +
+                       _manSshConfig('ProxyCommand')
+               );
+               o.modalonly = true;
+
                return m.render();
        },
 });