reaver: use 65536 as snaplen with pcap
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 8 Dec 2016 05:25:39 +0000 (13:25 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 8 Dec 2016 15:54:30 +0000 (09:54 -0600)
It should fix issue #3333.  The patch was formed with help from
t6x/reaver-wps-fork-t6x#101

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/reaver/Makefile
net/reaver/patches/0101-pcap-use-65536-as-snaplen.patch [new file with mode: 0644]

index 7700c9ea36d7b6b57410ed67b516f897180ae13f..1a499de7c64ab8a9e65d1061f49e046e358f114b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=reaver
 PKG_VERSION:=1.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/net/reaver/patches/0101-pcap-use-65536-as-snaplen.patch b/net/reaver/patches/0101-pcap-use-65536-as-snaplen.patch
new file mode 100644 (file)
index 0000000..03f4318
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/init.c.orig  2016-12-08 13:23:17.386891467 +0800
++++ b/src/init.c       2016-12-08 13:23:20.850892551 +0800
+@@ -121,7 +121,7 @@ pcap_t *capture_init(char *capture_sourc
+       pcap_t *handle = NULL;
+       char errbuf[PCAP_ERRBUF_SIZE] = { 0 };
+       
+-      handle = pcap_open_live(capture_source, BUFSIZ, 1, 0, errbuf);
++      handle = pcap_open_live(capture_source, 65536, 1, 0, errbuf);
+       if(!handle)
+       {
+               handle = pcap_open_offline(capture_source, errbuf);