add ptunnel (PingTunnel) (thanks to Romain Beauxis)
authorNicolas Thill <nico@openwrt.org>
Thu, 15 Dec 2005 00:58:07 +0000 (00:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 15 Dec 2005 00:58:07 +0000 (00:58 +0000)
SVN-Revision: 2676

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/ptunnel/Config.in [new file with mode: 0644]
openwrt/package/ptunnel/Makefile [new file with mode: 0644]
openwrt/package/ptunnel/ipkg/ptunnel.control [new file with mode: 0644]

index 58612d47239698b993698900ce7e1711548161dd..9cab42c184aeb1dd109246817f79cbec21d1c8ea 100644 (file)
@@ -105,6 +105,7 @@ source "package/ppp/Config.in"
 source "package/rp-pppoe/Config.in"
 source "package/pptp/Config.in"
 source "package/pptpd/Config.in"
+source "package/ptunnel/Config.in"
 source "package/quagga/Config.in"
 source "package/raddump/Config.in"
 source "package/rarpd/Config.in"
index 638a0bc51c8fb079ef75bd25d482ccd085e6992c..0ce945e3bcf62f472a2e9640403e1afd5effde82 100644 (file)
@@ -163,6 +163,7 @@ package-$(BR2_PACKAGE_PPP) += ppp
 package-$(BR2_PACKAGE_PPTP) += pptp
 package-$(BR2_PACKAGE_PPTPD) += pptpd
 package-$(BR2_PACKAGE_PSYBNC) += psybnc
+package-$(BR2_PACKAGE_PTUNNEL) += ptunnel
 package-$(BR2_PACKAGE_QUAGGA) += quagga
 package-$(BR2_PACKAGE_RADVD) += radvd
 package-$(BR2_PACKAGE_RARPD) += rarpd
@@ -305,6 +306,7 @@ peercast-compile: uclibc++-compile
 portmap-compile: tcp_wrappers-compile
 postgresql-compile: zlib-compile
 ppp-compile: linux-atm-compile
+ptunnel-compile: libpcap-compile
 quagga-compile: readline-compile ncurses-compile
 raddump-compile: openssl-compile libpcap-compile
 rarpd-compile: libnet-compile
diff --git a/openwrt/package/ptunnel/Config.in b/openwrt/package/ptunnel/Config.in
new file mode 100644 (file)
index 0000000..bea6e01
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_PTUNNEL
+       prompt "ptunnel........................... Tunnel TCP connections over ICMP packets"
+       tristate 
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBPCAP
+       select BR2_PACKAGE_LIBPTHREAD
+       help
+         ptunnel is an application that allows you to reliably tunnel TCP connections to
+         a remote host using ICMP echo request and reply packets, commonly known as ping
+         requests and replies. It acts as a proxy and can handle sockets and secured
+         identification.
+
+         http://www.cs.uit.no/~daniels/PingTunnel/
+
diff --git a/openwrt/package/ptunnel/Makefile b/openwrt/package/ptunnel/Makefile
new file mode 100644 (file)
index 0000000..8330cb0
--- /dev/null
@@ -0,0 +1,69 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ptunnel
+PKG_VERSION:=0.61
+PKG_RELEASE:=1
+PKG_MD5SUM:=b45f73875f2af48f101816672f83a5fe
+
+PKG_SOURCE_URL:=http://www.cti.ecp.fr/~beauxir5/ptunnel/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PTUNNEL,ptunnel,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               BUILD_CC=$(TARGET_CC) \
+               HOSTCC=$(HOSTCC) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ac_cv_linux_vers=2 \
+               td_cv_buggygetaddrinfo="no" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --disable-static \
+                       --with-gnu-ld \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_PTUNNEL):
+       install -m0755 -d $(IDIR_PTUNNEL)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/ptunnel $(IDIR_PTUNNEL)/usr/sbin/
+       $(RSTRIP) $(IDIR_PTUNNEL)
+       $(IPKG_BUILD) $(IDIR_PTUNNEL) $(PACKAGE_DIR)
diff --git a/openwrt/package/ptunnel/ipkg/ptunnel.control b/openwrt/package/ptunnel/ipkg/ptunnel.control
new file mode 100644 (file)
index 0000000..0020f13
--- /dev/null
@@ -0,0 +1,5 @@
+Package: ptunnel
+Priority: optional
+Section: net
+Description: Tunnel TCP connections over ICMP packets
+Depends: libpcap, libpthread