openvswitch: bump to version 2.14.0
authorYousong Zhou <yszhou4tech@gmail.com>
Tue, 25 Aug 2020 03:47:16 +0000 (11:47 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Tue, 25 Aug 2020 07:50:32 +0000 (15:50 +0800)
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/openvswitch/Makefile
net/openvswitch/openvswitch.mk
net/openvswitch/patches/0001-netdev-linux-Let-interface-flag-survive-internal-por.patch
net/openvswitch/patches/0002-python-separate-host-target-python-for-cross-compile.patch
net/openvswitch/patches/0003-ovs-lib-fix-install_dir.patch
net/openvswitch/patches/0004-build-trim-build.patch
net/openvswitch/patches/0005-datapath-unexport-LDFLAGS.patch
net/openvswitch/patches/0006-datapath-allow-passing-additional-OVS_KERNEL_MAKE_FL.patch
net/openvswitch/patches/0007-build-only-link-libopenvswitch-with-libunwind-libunb.patch [new file with mode: 0644]
net/openvswitch/patches/0009-build-only-link-libopenvswitch-with-libunwind-libunb.patch [deleted file]
net/openvswitch/patches/0010-acinclude-Fix-build-with-kernels-with-prandom-moved-.patch [deleted file]

index 70381abbda55e21a95221b559287b4b0a2f1d0af..b1ce371ef5a0f1d29574bfec571b95f0d0827ae6 100644 (file)
@@ -20,7 +20,7 @@ PKG_VERSION:=$(ovs_version)
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
-PKG_HASH:=bf5b19d35c820903c141a40f2a949e2ee047c8c0fd7c5e6e12d2239ed5c90026
+PKG_HASH:=4171e52a8c0ffe160c1daa6687219d902a2a6969b296d223d8dac980ab99a260
 
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
@@ -43,7 +43,7 @@ include ../../lang/python/python3-package.mk
 
 ovs_kmod_packages:=
 ovs_kmod_intree_kernel_patchver_min:=3.10
-ovs_kmod_intree_kernel_patchver_max:=5.0
+ovs_kmod_intree_kernel_patchver_max:=5.5
 ovs_kmod_intree_not_supported:=$(strip $(call kernel_patchver_lt,$(ovs_kmod_intree_kernel_patchver_min))$(call kernel_patchver_gt,$(ovs_kmod_intree_kernel_patchver_max)))
 ovs_kmod_intree_dir:=$(PKG_BUILD_DIR)/datapath/linux
 ovs_kmod_upstream_dir:=$(LINUX_DIR)/net/openvswitch
index 24660e03eda11126f8d1c7d5d81b94870e679cf0..85ce43ac95e3726852304fd6b6c2be6e5d0745fc 100644 (file)
@@ -5,7 +5,7 @@
 
 # Versions
 
-ovs_version:=2.13.1
+ovs_version:=2.14.0
 ovs_builddir=$(KERNEL_BUILD_DIR)/openvswitch-$(ovs_version)
 
 # Shared vars, macros
index 2a049528e16fa0929dff69a15738ff91f96faf86..90ad6ffa659df80d3cfca5c2a3c1c936bdeca682 100644 (file)
@@ -1,4 +1,4 @@
-From 66f96259c596f8f303bd98e5323a447cd60adbb2 Mon Sep 17 00:00:00 2001
+From 974dc36a87274d7bae13e7dddd3364fecf5b3e7c Mon Sep 17 00:00:00 2001
 From: Helmut Schaa <helmut.schaa@googlemail.com>
 Date: Wed, 8 Jan 2014 13:48:49 +0100
 Subject: [PATCH] netdev-linux: Let interface flag survive internal port setup
@@ -17,10 +17,10 @@ Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
  1 file changed, 7 insertions(+), 1 deletion(-)
 
 diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
-index c6f3d2740..136668b1d 100644
+index fe7fb9b29..63407ba1b 100644
 --- a/lib/netdev-linux.c
 +++ b/lib/netdev-linux.c
-@@ -3461,7 +3461,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
+@@ -3469,7 +3469,13 @@ update_flags(struct netdev_linux *netdev, enum netdev_flags off,
      unsigned int old_flags, new_flags;
      int error = 0;
  
index bcd1ce1084bef75d68686e5cf26dc665191200fb..7903afed3db8598772d704ba2ea613254c5b47d6 100644 (file)
@@ -1,4 +1,4 @@
-From 29c5b1f1b53010a49d2ce1cc59060c334b1a40fc Mon Sep 17 00:00:00 2001
+From 54484e79aca0981ebc42ddc68487e6531da9b59d Mon Sep 17 00:00:00 2001
 From: Yousong Zhou <yszhou4tech@gmail.com>
 Date: Fri, 20 Mar 2020 15:11:31 +0800
 Subject: [PATCH] python: separate host/target python for cross-compile
@@ -10,7 +10,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
  2 files changed, 3 insertions(+), 1 deletion(-)
 
 diff --git a/Makefile.am b/Makefile.am
-index b279303d1..6140b2c7f 100644
+index 27ef9e4b4..7effb5fec 100644
 --- a/Makefile.am
 +++ b/Makefile.am
 @@ -60,7 +60,7 @@ endif
@@ -23,7 +23,7 @@ index b279303d1..6140b2c7f 100644
  ALL_LOCAL =
  BUILT_SOURCES =
 diff --git a/m4/openvswitch.m4 b/m4/openvswitch.m4
-index add3aabcc..ada31c491 100644
+index 6fe79297e..f2e0169f8 100644
 --- a/m4/openvswitch.m4
 +++ b/m4/openvswitch.m4
 @@ -383,6 +383,8 @@ else:
index 4ff93c6664c9f41df0bc74569a526e7ea86e497e..363bc95fc8d629165e4be730e4a1b04a70b9d147 100644 (file)
@@ -1,4 +1,4 @@
-From 1c0697cb4b57e85deafc0d518b68e0b13ba2995b Mon Sep 17 00:00:00 2001
+From 444991b95ed25d58c3cd1646fa823620380b6ce6 Mon Sep 17 00:00:00 2001
 From: Yousong Zhou <yszhou4tech@gmail.com>
 Date: Wed, 14 Mar 2018 16:44:13 +0800
 Subject: [PATCH] ovs-lib: fix install_dir()
index 05fc8b8305f1e4a1544bdf41cc100839e700d97a..36fb946fc4f701ffad5ae73aec7ad6831ec503f4 100644 (file)
@@ -1,4 +1,4 @@
-From 3ee8ab22699b503b591b6abb4a2db89ac1881ea6 Mon Sep 17 00:00:00 2001
+From 31514742de07d595ac23c2b0abf0e092f8b26140 Mon Sep 17 00:00:00 2001
 From: Yousong Zhou <zhouyousong@yunionyun.com>
 Date: Tue, 21 Aug 2018 13:02:21 +0000
 Subject: [PATCH] build: trim build
@@ -9,7 +9,7 @@ Signed-off-by: Yousong Zhou <zhouyousong@yunionyun.com>
  1 file changed, 2 deletions(-)
 
 diff --git a/Makefile.am b/Makefile.am
-index 6140b2c7f..d9f9457fa 100644
+index 7effb5fec..d6df91e8b 100644
 --- a/Makefile.am
 +++ b/Makefile.am
 @@ -475,12 +475,10 @@ dist-docs:
index 6b4d64254b96cfb733000889d9d5967c6a8c7067..8bd16ba9573414b03c9e887938f5bd29e63e528b 100644 (file)
@@ -1,4 +1,4 @@
-From b2c26315339fc17d0ad9d0009321671850cc7295 Mon Sep 17 00:00:00 2001
+From 2939a31ad57f81556afdf5112ee1d68bd2e3f012 Mon Sep 17 00:00:00 2001
 From: Yousong Zhou <yszhou4tech@gmail.com>
 Date: Mon, 16 Mar 2020 15:18:16 +0800
 Subject: [PATCH] datapath: unexport LDFLAGS
index 411d53ce2fd12ced1b68a9fab4a67051b0ea8ff8..305d2a413ef20a0cd00759fa230240d4445bd03b 100644 (file)
@@ -1,4 +1,4 @@
-From f29d4866cf566c916000426e0c206db008be4fb3 Mon Sep 17 00:00:00 2001
+From 1df5a0eaf78e93e21d21f1438afbe5fa8a37ea61 Mon Sep 17 00:00:00 2001
 From: Yousong Zhou <yszhou4tech@gmail.com>
 Date: Tue, 26 May 2020 22:45:53 +0800
 Subject: [PATCH] datapath: allow passing additional $(OVS_KERNEL_MAKE_FLAGS)
diff --git a/net/openvswitch/patches/0007-build-only-link-libopenvswitch-with-libunwind-libunb.patch b/net/openvswitch/patches/0007-build-only-link-libopenvswitch-with-libunwind-libunb.patch
new file mode 100644 (file)
index 0000000..9db7ca9
--- /dev/null
@@ -0,0 +1,60 @@
+From e81ccb671014db62bf622cd8f960d7930d27d9dc Mon Sep 17 00:00:00 2001
+From: Yousong Zhou <yszhou4tech@gmail.com>
+Date: Wed, 29 Jul 2020 17:29:14 +0800
+Subject: [PATCH] build: only link libopenvswitch with libunwind, libunbound
+
+Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
+---
+ lib/automake.mk          | 2 ++
+ lib/libopenvswitch.pc.in | 2 +-
+ m4/openvswitch.m4        | 6 ++++--
+ 3 files changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/lib/automake.mk b/lib/automake.mk
+index 380a67228..610f3d940 100644
+--- a/lib/automake.mk
++++ b/lib/automake.mk
+@@ -10,6 +10,8 @@ lib_LTLIBRARIES += lib/libopenvswitch.la
+ lib_libopenvswitch_la_LIBADD = $(SSL_LIBS)
+ lib_libopenvswitch_la_LIBADD += $(CAPNG_LDADD)
+ lib_libopenvswitch_la_LIBADD += $(LIBBPF_LDADD)
++lib_libopenvswitch_la_LIBADD += $(LIBUNBOUND_LDADD)
++lib_libopenvswitch_la_LIBADD += $(LIBUNWIND_LDADD)
+ if WIN32
+diff --git a/lib/libopenvswitch.pc.in b/lib/libopenvswitch.pc.in
+index 2a3f2ca7b..c8d02eb5a 100644
+--- a/lib/libopenvswitch.pc.in
++++ b/lib/libopenvswitch.pc.in
+@@ -7,5 +7,5 @@ Name: libopenvswitch
+ Description: Open vSwitch library
+ Version: @VERSION@
+ Libs: -L${libdir} -lopenvswitch
+-Libs.private: @LIBS@
++Libs.private: @LIBS@ @SSL_LIBS@ @CAPNG_LDADD@ @LIBBPF_LDADD@ @LIBUNBOUND_LDADD@ @LIBUNWIND_LDADD@
+ Cflags: -I${includedir}/openvswitch
+diff --git a/m4/openvswitch.m4 b/m4/openvswitch.m4
+index f2e0169f8..e000c1cc5 100644
+--- a/m4/openvswitch.m4
++++ b/m4/openvswitch.m4
+@@ -657,7 +657,8 @@ AC_DEFUN([OVS_CHECK_UNBOUND],
+   [AC_CHECK_LIB(unbound, ub_ctx_create, [HAVE_UNBOUND=yes], [HAVE_UNBOUND=no])
+    if test "$HAVE_UNBOUND" = yes; then
+      AC_DEFINE([HAVE_UNBOUND], [1], [Define to 1 if unbound is detected.])
+-     LIBS="$LIBS -lunbound"
++     LIBUNBOUND_LDADD="-lunbound"
++     AC_SUBST(LIBUNBOUND_LDADD)
+    fi
+    AM_CONDITIONAL([HAVE_UNBOUND], [test "$HAVE_UNBOUND" = yes])
+    AC_SUBST([HAVE_UNBOUND])])
+@@ -669,7 +670,8 @@ AC_DEFUN([OVS_CHECK_UNWIND],
+    [HAVE_UNWIND=no])
+    if test "$HAVE_UNWIND" = yes; then
+      AC_DEFINE([HAVE_UNWIND], [1], [Define to 1 if unwind is detected.])
+-     LIBS="$LIBS -lunwind"
++     LIBUNWIND_LDADD="-lunwind"
++     AC_SUBST(LIBUNWIND_LDADD)
+    fi
+    AM_CONDITIONAL([HAVE_UNWIND], [test "$HAVE_UNWIND" = yes])
+    AC_SUBST([HAVE_UNWIND])])
diff --git a/net/openvswitch/patches/0009-build-only-link-libopenvswitch-with-libunwind-libunb.patch b/net/openvswitch/patches/0009-build-only-link-libopenvswitch-with-libunwind-libunb.patch
deleted file mode 100644 (file)
index 106e748..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-From 6324f0c594e3773c754861e630fff694d1bec15a Mon Sep 17 00:00:00 2001
-From: Yousong Zhou <yszhou4tech@gmail.com>
-Date: Wed, 29 Jul 2020 17:29:14 +0800
-Subject: [PATCH] build: only link libopenvswitch with libunwind, libunbound
-
-Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
----
- lib/automake.mk          | 2 ++
- lib/libopenvswitch.pc.in | 2 +-
- m4/openvswitch.m4        | 6 ++++--
- 3 files changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/lib/automake.mk b/lib/automake.mk
-index 95925b57c..df95bea10 100644
---- a/lib/automake.mk
-+++ b/lib/automake.mk
-@@ -10,6 +10,8 @@ lib_LTLIBRARIES += lib/libopenvswitch.la
- lib_libopenvswitch_la_LIBADD = $(SSL_LIBS)
- lib_libopenvswitch_la_LIBADD += $(CAPNG_LDADD)
- lib_libopenvswitch_la_LIBADD += $(LIBBPF_LDADD)
-+lib_libopenvswitch_la_LIBADD += $(LIBUNBOUND_LDADD)
-+lib_libopenvswitch_la_LIBADD += $(LIBUNWIND_LDADD)
- if WIN32
- lib_libopenvswitch_la_LIBADD += ${PTHREAD_LIBS}
-diff --git a/lib/libopenvswitch.pc.in b/lib/libopenvswitch.pc.in
-index 2a3f2ca7b..c8d02eb5a 100644
---- a/lib/libopenvswitch.pc.in
-+++ b/lib/libopenvswitch.pc.in
-@@ -7,5 +7,5 @@ Name: libopenvswitch
- Description: Open vSwitch library
- Version: @VERSION@
- Libs: -L${libdir} -lopenvswitch
--Libs.private: @LIBS@
-+Libs.private: @LIBS@ @SSL_LIBS@ @CAPNG_LDADD@ @LIBBPF_LDADD@ @LIBUNBOUND_LDADD@ @LIBUNWIND_LDADD@
- Cflags: -I${includedir}/openvswitch
-diff --git a/m4/openvswitch.m4 b/m4/openvswitch.m4
-index ada31c491..6165cc7b1 100644
---- a/m4/openvswitch.m4
-+++ b/m4/openvswitch.m4
-@@ -623,7 +623,8 @@ AC_DEFUN([OVS_CHECK_UNBOUND],
-   [AC_CHECK_LIB(unbound, ub_ctx_create, [HAVE_UNBOUND=yes], [HAVE_UNBOUND=no])
-    if test "$HAVE_UNBOUND" = yes; then
-      AC_DEFINE([HAVE_UNBOUND], [1], [Define to 1 if unbound is detected.])
--     LIBS="$LIBS -lunbound"
-+     LIBUNBOUND_LDADD="-lunbound"
-+     AC_SUBST(LIBUNBOUND_LDADD)
-    fi
-    AM_CONDITIONAL([HAVE_UNBOUND], [test "$HAVE_UNBOUND" = yes])
-    AC_SUBST([HAVE_UNBOUND])])
-@@ -635,7 +636,8 @@ AC_DEFUN([OVS_CHECK_UNWIND],
-    [HAVE_UNWIND=no])
-    if test "$HAVE_UNWIND" = yes; then
-      AC_DEFINE([HAVE_UNWIND], [1], [Define to 1 if unwind is detected.])
--     LIBS="$LIBS -lunwind"
-+     LIBUNWIND_LDADD="-lunwind"
-+     AC_SUBST(LIBUNWIND_LDADD)
-    fi
-    AM_CONDITIONAL([HAVE_UNWIND], [test "$HAVE_UNWIND" = yes])
-    AC_SUBST([HAVE_UNWIND])])
diff --git a/net/openvswitch/patches/0010-acinclude-Fix-build-with-kernels-with-prandom-moved-.patch b/net/openvswitch/patches/0010-acinclude-Fix-build-with-kernels-with-prandom-moved-.patch
deleted file mode 100644 (file)
index ef428d5..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From f639ec9b25b2758a07d214f7755f1ae0f764e949 Mon Sep 17 00:00:00 2001
-Message-Id: <f639ec9b25b2758a07d214f7755f1ae0f764e949.1597434688.git.mschiffer@universe-factory.net>
-From: Ilya Maximets <i.maximets@ovn.org>
-Date: Wed, 12 Aug 2020 10:57:07 +0200
-Subject: [PATCH] acinclude: Fix build with kernels with prandom* moved to
- prandom.h.
-
-Recent commit c0842fbc1b18 ("random32: move the pseudo-random 32-bit
-definitions to prandom.h") in upstream kernel moved the definition
-of prandom_* functions from random.h to prandom.h.  This change was
-also backported to stable kernels.
-
-Fixing our configure script to look for these functions in a new
-location and avoid build failures:
-
-  datapath/linux/compat/include/linux/random.h:11:19:
-    error: redefinition of 'prandom_u32_max'
-
-Acked-by: Greg Rose <gvrose8192@gmail.com>
-Signed-off-by: Ilya Maximets <i.maximets@ovn.org>
-(cherry picked from commit 0047ca3a0290f1ef954f2c76b31477cf4b9755f5)
----
- acinclude.m4 | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/acinclude.m4 b/acinclude.m4
-index b474422f52c8..7f028836f54c 100644
---- a/acinclude.m4
-+++ b/acinclude.m4
-@@ -781,6 +781,10 @@ AC_DEFUN([OVS_CHECK_LINUX_COMPAT], [
-                   [prandom_u32[[\(]]],
-                   [OVS_DEFINE([HAVE_PRANDOM_U32])])
-   OVS_GREP_IFELSE([$KSRC/include/linux/random.h], [prandom_u32_max])
-+  OVS_GREP_IFELSE([$KSRC/include/linux/prandom.h],
-+                  [prandom_u32[[\(]]],
-+                  [OVS_DEFINE([HAVE_PRANDOM_U32])])
-+  OVS_GREP_IFELSE([$KSRC/include/linux/prandom.h], [prandom_u32_max])
-   OVS_GREP_IFELSE([$KSRC/include/net/rtnetlink.h], [get_link_net])
-   OVS_GREP_IFELSE([$KSRC/include/net/rtnetlink.h], [name_assign_type])
--- 
-2.28.0
-