softethervpn: add -Wl,-rpath to HOST_LDFLAGS
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Fri, 21 Dec 2018 16:29:05 +0000 (14:29 -0200)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Fri, 21 Dec 2018 17:55:38 +0000 (15:55 -0200)
Avoids failures related to the absence of a matching libreadline.so in
the host system.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
net/softethervpn/Makefile

index 1d7bcd4e7a6b2e8b9a0139495734c5acd91a43a1..4a480d497d37446cb740edad605e8b8f8c9a12b6 100644 (file)
@@ -39,6 +39,7 @@ HOST_MAKE_FLAGS += -C $(HOST_BUILD_DIR)
 # Select 32 or 64 bit Makefile for host build depending on host architecture
 HOST_MAKE_FLAGS += -f src/makefiles/linux_$(if $(shell uname -m | grep 64),64,32)bit.mak
 
+HOST_LDFLAGS += -Wl,-rpath="$(STAGING_DIR_HOSTPKG)/lib"
 # Prevent calling upstream configure
 define Host/Configure
 endef