docker-compose: Update to version 2.4.0
authorJavier Marcet <javier@marcet.info>
Sat, 2 Apr 2022 10:48:49 +0000 (12:48 +0200)
committerRosen Penev <rosenp@gmail.com>
Sun, 3 Apr 2022 17:51:08 +0000 (10:51 -0700)
What's Changed:

 - pass interactive flag to ExecOptions for the RunExec command by
 @glours
 - go.mod: pin k8s version to fix build on go1.16, and update buildx
 to v0.8.1 by @thaJeztah
 - support cache_from|to|no|pull by @ndeloof
 - fix race condition on start-stop e2e tests running in parrallel by
 @glours
 - Add support of ssh authentications defined in compose file or via
 cli… by @glours
 - fix typo in ssh option description by @mschoettle
 - Takes COMPOSE_PROJECT_NAME into consideration on commands by
 @ulyssessouza
 - Remove dead warning code by @ulyssessouza
 - Fix down command without any resource to delete by @ulyssessouza
 - vendor: github.com/containerd/containerd v1.6.2 by @thaJeztah

New Contributors:

 - @mschoettle made their first contribution

Signed-off-by: Javier Marcet <javier@marcet.info>
utils/docker-compose/Makefile

index 8f549f81cac40ce2577ad9359fc80d35f82e7fb7..7744698eb9f6741f34b88e13f88a89d4fdb26bc4 100644 (file)
@@ -1,14 +1,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=compose
-PKG_VERSION:=2.3.4
+PKG_VERSION:=2.4.0
 PKG_RELEASE:=$(AUTORELEASE)
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
 PKG_SOURCE:=v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/docker/compose/tar.gz/v${PKG_VERSION}?
-PKG_HASH:=10657bbca710b7bfe7e17f259a4ab6cf69b890e7ac4b3bfc2444ef3086bd89cb
+PKG_HASH:=b0507aed3b86900f5199309dcfb8b2d4081d94e8ec045eec2bada8280dc9901b
 
 PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>