luci-base: always link core.so with libcrypt to satisfy glibc builds
authorJo-Philipp Wich <jo@mein.io>
Thu, 27 Oct 2022 10:36:33 +0000 (12:36 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 27 Oct 2022 10:36:33 +0000 (12:36 +0200)
Fixes the following runtime error on glibc based builds:

    Runtime error: Unable to dlopen file ...: undefined symbol: crypt
    In module(), file /usr/share/ucode/luci/dispatcher.uc, line 1, byte 1:
      called from anonymous function (/www/cgi-bin/luci:7:21)

Ref: https://forum.openwrt.org/t/x/137250/18
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
modules/luci-base/src/Makefile

index 896aeb0a386569c596f961a0cf46ca663f67708d..ad309e5c6b38c1fa6b792951c87f4bce58645d83 100644 (file)
@@ -10,7 +10,7 @@ lib/plural_formula.c: lib/plural_formula.y contrib/lemon
 lib/lmo.c: lib/plural_formula.c
 
 core.so: lib/luci.o lib/lmo.o lib/plural_formula.o
-       $(CC) $(LDFLAGS) -shared -o $@ $^
+       $(CC) $(LDFLAGS) -shared -lcrypt -o $@ $^
 
 version.uc:
        echo "export const revision = '$(LUCI_VERSION)', branch = '$(LUCI_GITBRANCH)';" > $@