libpcap: fix pcap-config
authorRosen Penev <rosenp@gmail.com>
Tue, 15 Dec 2020 01:56:17 +0000 (17:56 -0800)
committerPetr Štetiar <ynezz@true.cz>
Tue, 22 Dec 2020 17:59:10 +0000 (18:59 +0100)
pcap-config as installed is using OS paths instead of OpenWrt ones.

Take fix from libpng and adjust as needed.

This problem seems to occur on Arch Linux and not on Debian/Fedora
based distros. No idea why.

Remove CMAKE_INSTALL as there is now an InstallDev section.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/libpcap/Makefile

index 1a2cdcdd98473d6a306929df368b1cca2a140ef8..35ceb18c29a4c6168b059eadc637fa3f90632193 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpcap
 PKG_VERSION:=1.9.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.us.tcpdump.org/release/ \
@@ -18,7 +18,6 @@ PKG_HASH:=635237637c5b619bcceba91900666b64d56ecb7be63f298f601ec786ce087094
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-CMAKE_INSTALL:=1
 PKG_ASLR_PIE_REGULAR:=1
 PKG_BUILD_PARALLEL:=1
 
@@ -71,6 +70,15 @@ CMAKE_OPTIONS += $(if $(CONFIG_PCAP_HAS_NETFILTER) ,,-DPCAP_SUPPORT_NETFILTER=OF
 
 CMAKE_OPTIONS += $(if $(CONFIG_IPV6),-DINET6=ON,-DINET6=OFF)
 
+define Build/InstallDev
+       $(call Build/InstallDev/cmake,$(1))
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(1)/usr/bin/pcap-config
+       $(INSTALL_DIR) $(2)/bin
+       $(LN) ../../usr/bin/pcap-config $(2)/bin/pcap-config
+endef
+
 define Package/libpcap/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcap.so.* $(1)/usr/lib/