horst: fix compilation with ncurses 6.3 18129/head
authorRosen Penev <rosenp@gmail.com>
Mon, 21 Mar 2022 04:12:06 +0000 (21:12 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 21 Mar 2022 22:14:50 +0000 (15:14 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/horst/Makefile
net/horst/patches/010-ncurses63.patch [new file with mode: 0644]

index a9dfc17a9ad784bec03666e244cb167208cac2ca..80d45092ddf69a72a32d90db8098a24cc494a581 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=horst
 PKG_VERSION:=5.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/br101/horst/archive/v$(PKG_VERSION)/
diff --git a/net/horst/patches/010-ncurses63.patch b/net/horst/patches/010-ncurses63.patch
new file mode 100644 (file)
index 0000000..3b6cebb
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/display-main.c
++++ b/display-main.c
+@@ -53,7 +53,7 @@ static struct ewma bpsn_avg;
+ void print_dump_win(const char *str, int refresh)
+ {
+       wattron(dump_win, RED);
+-      wprintw(dump_win, str);
++      wprintw(dump_win, "%s", str);
+       wattroff(dump_win, RED);
+       if (refresh)
+               wrefresh(dump_win);
+--- a/display.c
++++ b/display.c
+@@ -86,7 +86,7 @@ print_centered(WINDOW* win, int line, in
+       vsnprintf(buf, cols, fmt, ap);
+       va_end(ap);
+-      mvwprintw(win, line, cols / 2 - strlen(buf) / 2, buf);
++      mvwprintw(win, line, cols / 2 - strlen(buf) / 2, "%s", buf);
+       free(buf);
+ }