Bump linuxptp to version 1.9.2 5890/head
authorWojciech Dubowik <klute99@gmail.com>
Mon, 9 Apr 2018 12:02:00 +0000 (14:02 +0200)
committerWojciech Dubowik <Wojciech.Dubowik@neratec.com>
Mon, 9 Apr 2018 13:01:15 +0000 (15:01 +0200)
Signed-off-by: Wojciech Dubowik <klute99@gmail.com>
net/linuxptp/Makefile
net/linuxptp/patches/030-upstream.patch [deleted file]

index df916d1c82aa6990b5b7a72b7a8c5b9d8142b029..85b66464680364d156fac98991aad404496f3e82 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linuxptp
-PKG_VERSION:=1.9
+PKG_VERSION:=1.9.2
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Wojciech Dubowik <Wojciech.Dubowik@neratec.com>
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)/v$(PKG_VERSION)
-PKG_HASH:=5fb1e4889ccb06f887fc2972fc8b89d17a4cb6355406854f916ebc8d7f51580e
+PKG_HASH:=7f662e65c66c37ff211dc525476626875c2b74162ded05c8a25d036fb963b8d0
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
diff --git a/net/linuxptp/patches/030-upstream.patch b/net/linuxptp/patches/030-upstream.patch
deleted file mode 100644 (file)
index bdb8fb7..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From d14f11fd329a7da94c0d0190a169f743eb91031b Mon Sep 17 00:00:00 2001
-From: Richard Cochran <richardcochran@gmail.com>
-Date: Mon, 2 Apr 2018 20:19:51 -0700
-Subject: [PATCH] msg: Append multiple TLVs correctly.
-
-The logic that adds TLVs to the end of a message mixes up the 'L'
-length in "TLV" with the total TLV length.  As a result, the second
-and subsequent TLVs will corrupt the previous TLV in the buffer.  This
-patch corrects the code to find the correct offset for the second and
-following appended TLVs.
-
-Note that the stack does not currently trigger this latent bug because
-only single TLVs are appended.
-
-Fixes: 4a8877f90462 ("msg: Introduce method for appending multiple TLVs on transmit.")
-
-Signed-off-by: Richard Cochran <richardcochran@gmail.com>
----
- msg.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/msg.c b/msg.c
-index b7e1053..c004568 100644
---- a/msg.c
-+++ b/msg.c
-@@ -151,6 +151,8 @@ static struct tlv_extra *msg_tlv_prepare(struct ptp_message *msg, int length)
-       tmp = TAILQ_LAST(&msg->tlv_list, tlv_list);
-       if (tmp) {
-               ptr = (uint8_t *) tmp->tlv;
-+              ptr += sizeof(tmp->tlv->type);
-+              ptr += sizeof(tmp->tlv->length);
-               ptr += tmp->tlv->length;
-       }
--- 
-2.7.4
-