lxc: export systemd cgroups after install
authorMichal Vasilek <michal.vasilek@nic.cz>
Fri, 8 Apr 2022 20:49:53 +0000 (22:49 +0200)
committerRosen Penev <rosenp@gmail.com>
Sun, 15 May 2022 04:28:48 +0000 (21:28 -0700)
otherwise, a user would have to either manually run /etc/init.d/lxc-auto
boot or reboot the system to start using lxc.

Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
utils/lxc/Makefile

index 19fd00f5ec49456a12b9d1f3630af69076ec06f2..4a22d56aa0ee8515720d27f94eb8afb1560b5f7b 100644 (file)
@@ -177,6 +177,10 @@ define Package/lxc-auto/install
        $(INSTALL_BIN) ./files/lxc-auto.init $(1)/etc/init.d/lxc-auto
 endef
 
+define Package/lxc-auto/postinst
+[ "$${PKG_UPGRADE}" = "0" ] && /etc/init.d/lxc-auto boot
+endef
+
 define Package/lxc-common/conffiles
 /etc/lxc/default.conf
 /etc/lxc/lxc.conf