cryptodev: simplify for Jo's parameter passing 5087/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Tue, 24 Oct 2017 21:19:34 +0000 (15:19 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Tue, 7 Nov 2017 23:47:45 +0000 (16:47 -0700)
Don't need to have a bare /etc/modules.d/ file since we can cleanly
synthesize one now.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
utils/cryptodev-linux/Makefile
utils/cryptodev-linux/files/cryptodev.modules [deleted file]

index 33a901b6c1ae8fad8355ff79b2831da32ba3f4d7..a6a741f18c9928bef0d5c9964cec8aea5190e7b2 100644 (file)
@@ -40,6 +40,7 @@ define KernelPackage/cryptodev
   FILES:= \
                $(PKG_BUILD_DIR)/cryptodev.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,$(CRYPTODEV_AUTOLOAD))
+  MODPARAMS.cryptodev:= cryptodev_verbosity=-1
 endef
 
 define KernelPackage/cryptodev/description
@@ -70,11 +71,4 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/crypto/cryptodev.h $(STAGING_DIR)/usr/include/crypto/
 endef
 
-define KernelPackage/cryptodev/install
-       $(INSTALL_DIR) $(1)/etc/modules.d
-       $(INSTALL_DATA) ./files/cryptodev.modules $(1)/etc/modules.d/50-cryptodev
-       $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
-       $(INSTALL_DIR) $(1)/usr/sbin
-endef
-
 $(eval $(call KernelPackage,cryptodev))
diff --git a/utils/cryptodev-linux/files/cryptodev.modules b/utils/cryptodev-linux/files/cryptodev.modules
deleted file mode 100644 (file)
index 48194e2..0000000
+++ /dev/null
@@ -1 +0,0 @@
-cryptodev cryptodev_verbosity=-1