treewide: Update ARM NEON/VFP detection 12133/head
authorJeffery To <jeffery.to@gmail.com>
Sun, 10 May 2020 19:02:05 +0000 (03:02 +0800)
committerJeffery To <jeffery.to@gmail.com>
Sun, 10 May 2020 19:10:20 +0000 (03:10 +0800)
With openwrt/openwrt@8dcc1087602e2dd606e4f6e81a06aee62cfd4f4c, the ARM
FPU compiler options are no longer part of CONFIG_TARGET_OPTIMIZATION.

This updates various packages that look for NEON/VFP support to search
CONFIG_CPU_TYPE instead.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
libs/libpng/Makefile
libs/opus/Makefile
multimedia/ffmpeg/Makefile
sound/mpg123/Makefile
sound/pulseaudio/Makefile

index 685a43b5d5305c0902ecef710bf6321de07f5abd..5e31a44b8005f4f158db51de3b18db14e188d478 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libpng
 PKG_VERSION:=1.6.37
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/libpng
@@ -40,7 +40,7 @@ TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
-       $(if $(findstring neon,$(CONFIG_TARGET_OPTIMIZATION)),--enable-hardware-optimizations=yes --enable-arm-neon=yes)
+       $(if $(findstring neon,$(CONFIG_CPU_TYPE)),--enable-hardware-optimizations=yes --enable-arm-neon=yes)
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin
index 689b7c0ea990d92687b7fe3828a27f287b4bb14d..1c106128f3e31281a351772ea0fbe3f7e39278fc 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=opus
 PKG_VERSION:=1.3.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://archive.mozilla.org/pub/opus
@@ -47,7 +47,7 @@ ifeq ($(CONFIG_SOFT_FLOAT),y)
                --enable-fixed-point
 endif
 
-ifneq ($(findstring neon,$(CONFIG_TARGET_OPTIMIZATION)),)
+ifneq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
        CONFIGURE_ARGS+= \
                --enable-fixed-point
 endif
index a5025d73a19ecc1cbfec94f707096d18c95852fc..269946991ef9cb3fabf2892585a50c70b1de6767 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
 PKG_VERSION:=4.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://ffmpeg.org/releases/
@@ -424,12 +424,12 @@ endif
 ifneq ($(findstring arm,$(CONFIG_ARCH)),)
        FFMPEG_CONFIGURE+= --enable-lto
 
-       ifneq ($(findstring vfp,$(CONFIG_TARGET_OPTIMIZATION)),)
+       ifneq ($(findstring vfp,$(CONFIG_CPU_TYPE)),)
                FFMPEG_CONFIGURE+= --enable-vfp
        else
                FFMPEG_CONFIGURE+= --disable-vfp
        endif
-       ifneq ($(findstring neon,$(CONFIG_TARGET_OPTIMIZATION)),)
+       ifneq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
                FFMPEG_CONFIGURE+= \
                        --enable-neon \
                        --enable-vfp
index eae0c04315526a49714a105f936bcc958a4adb6b..858ad15c9d51075c45c15662a1548aa494434120 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpg123
 PKG_VERSION:=1.25.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/mpg123
@@ -67,16 +67,14 @@ ifeq ($(CONFIG_SOFT_FLOAT),y)
        CONFIGURE_ARGS+= \
                --with-cpu=generic_nofpu \
                --enable-int-quality=yes
+else ifneq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
+       CONFIGURE_ARGS+= \
+               --with-cpu=arm_fpu
 else
        CONFIGURE_ARGS+= \
                --with-cpu=generic_fpu
 endif
 
-ifneq ($(findstring neon,$(CONFIG_TARGET_OPTIMIZATION)),)
-        CONFIGURE_ARGS+= \
-                --with-cpu=arm_fpu
-endif
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(INSTALL_DATA) \
index ac5454e1eaa8abafc1d3177284d2ec06c7190230..6a7ec3c522d0a3d9ae2ea0ede841e38121110f40 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pulseaudio
 PKG_VERSION:=13.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://freedesktop.org/software/pulseaudio/releases
@@ -148,7 +148,7 @@ TARGET_LDFLAGS += -Wl,--gc-sections -liconv
 define Build/Prepare
        $(call Build/Prepare/Default)
 ifneq ($(findstring arm,$(CONFIG_ARCH)),)
-ifeq ($(findstring neon,$(CONFIG_TARGET_OPTIMIZATION)),)
+ifeq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
        $(SED) '/remap_neon\.c/d' $(PKG_BUILD_DIR)/src/pulsecore/meson.build
 endif
 endif