libs/liblz4: update to v1.7.5 4468/head
authorDarik Horn <dajhorn@vanadac.com>
Sat, 10 Jun 2017 14:50:27 +0000 (10:50 -0400)
committerDarik Horn <dajhorn@vanadac.com>
Sat, 10 Jun 2017 14:58:17 +0000 (10:58 -0400)
From the upstream NEWS file:

  v1.7.5
  lz4hc : new high compression mode : levels 10-12 compress more and slower, by Przemyslaw Skibinski
  lz4cat : fix : works with relative path (#284) and stdin (#285) (reported by @beiDei8z)
  cli : fix minor notification when using -r recursive mode
  API : lz4frame : LZ4F_frameBound(0) gives upper bound of *flush() and *End() operations (#290, #280)
  doc : markdown version of man page, by Takayuki Matsuoka (#279)
  build : Makefile : fix make -jX lib+exe concurrency (#277)
  build : cmake : improvements by Michał Górny (#296)

  v1.7.4.2
  fix : Makefile : release build compatible with PIE and customized compilation directives provided through environment variables (#274, reported by Antoine Martin)

  v1.7.4
  Improved : much better speed in -mx32 mode
  cli : fix : Large file support in 32-bits mode on Mac OS-X
  fix : compilation on gcc 4.4 (#272), reported by Antoine Martin

  v1.7.3
  Changed : moved to versioning; package, cli and library have same version number
  Improved: Small decompression speed boost
  Improved: Small compression speed improvement on 64-bits systems
  Improved: Small compression ratio and speed improvement on small files
  Improved: Significant speed boost on ARMv6 and ARMv7
  Fix : better ratio on 64-bits big-endian targets
  Improved cmake build script, by Evan Nemerson
  New liblz4-dll project, by Przemyslaw Skibinki
  Makefile: Generates object files (*.o) for faster (re)compilation on low power systems
  cli : new : --rm and --help commands
  cli : new : preserved file attributes, by Przemyslaw Skibinki
  cli : fix : crash on some invalid inputs
  cli : fix : -t correctly validates lz4-compressed files, by Nick Terrell
  cli : fix : detects and reports fread() errors, thanks to Hiroshi Fujishima report #243
  cli : bench : new : -r recursive mode
  lz4cat : can cat multiple files in a single command line (#184)
  Added : doc/lz4_manual.html, by Przemyslaw Skibinski
  Added : dictionary compression and frame decompression examples, by Nick Terrell
  Added : Debianization, by Evgeniy Polyakov

Signed-off-by: Darik Horn <dajhorn@vanadac.com>
libs/liblz4/Makefile

index 58e0cd924effaea01343a8b55eb0161ae9fb3a1d..b75a4cccb326b0a1592a222351d23d4ddda11d8a 100644 (file)
@@ -8,9 +8,10 @@
 include $(TOPDIR)/rules.mk
 
 # Although liblz4 exports a major.minor.patch version, it isn't always
-# incremented for new releases, so use the release tag instead.
+# incremented for new releases. Check the NEWS file and instead use a
+# release tag when appropriate. (eg: PKG_VERSION:=r131)
 PKG_NAME:=liblz4
-PKG_VERSION:=r131
+PKG_VERSION:=v1.7.5
 PKG_RELEASE:=1
 
 PKG_LICENSE:=BSD-2-Clause