adguardhome: enable legacy openssl provider for nodejs
authorDobroslaw Kijowski <dobo90@gmail.com>
Wed, 8 Mar 2023 08:46:14 +0000 (09:46 +0100)
committerTianling Shen <cnsztl@gmail.com>
Wed, 8 Mar 2023 15:11:57 +0000 (23:11 +0800)
Currently compilation fails because of:
```
  opensslErrorStack: [ 'error:03000086:digital envelope routines::initialization error' ],
  library: 'digital envelope routines',
  reason: 'unsupported',
  code: 'ERR_OSSL_EVP_UNSUPPORTED'
```

What's interesting package gets built but when trying to access UI there's
`404: page not found` error.

It has been reported in multiple places:
* https://github.com/AdguardTeam/AdGuardHome/issues/5559
* https://github.com/AdguardTeam/AdGuardHome/issues/4595

Signed-off-by: Dobroslaw Kijowski <dobo90@gmail.com>
net/adguardhome/Makefile

index 309ffec6c3bbdba79f8b8d9463b75cf7309f4343..0ffe81debc959cf2a46c4a19690bb2d09c205408 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adguardhome
 PKG_VERSION:=0.107.24
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_VERSION:=v$(PKG_VERSION)
@@ -56,7 +56,7 @@ endef
 define Build/Compile
        ( \
                pushd $(PKG_BUILD_DIR) ; \
-               make js-deps js-build ; \
+               NODE_OPTIONS=--openssl-legacy-provider make js-deps js-build ; \
                popd ; \
                $(call GoPackage/Build/Compile) ; \
        )