luci.mk: adjust path of purged index cache files
authorJo-Philipp Wich <jo@mein.io>
Fri, 9 Sep 2022 21:34:32 +0000 (23:34 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 24 Oct 2022 23:03:37 +0000 (01:03 +0200)
The index cache files have been split into separate, dynamically named
Lua and JSON files a while ago, so adjust the remove command in the
postinstall script accordingly.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
luci.mk

diff --git a/luci.mk b/luci.mk
index cc77b9c60084433adecb33ca041c1fe3d7be91d2..9bb51698d90f149e72b32bf54bd7e94714475d9a 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -212,7 +212,7 @@ endef
 ifndef Package/$(PKG_NAME)/postinst
 define Package/$(PKG_NAME)/postinst
 [ -n "$${IPKG_INSTROOT}" ] || { \
-       rm -f /tmp/luci-indexcache
+       rm -f /tmp/luci-indexcache.*
        rm -rf /tmp/luci-modulecache/
        killall -HUP rpcd 2>/dev/null
        exit 0