curl: update to 7.85.0 19377/head
authorStan Grishin <stangri@melmac.ca>
Thu, 15 Sep 2022 19:41:31 +0000 (19:41 +0000)
committerStan Grishin <stangri@melmac.ca>
Thu, 15 Sep 2022 19:51:31 +0000 (19:51 +0000)
* https://curl.se/changes.html#7_85_0

Signed-off-by: Stan Grishin <stangri@melmac.ca>
net/curl/Config.in
net/curl/Makefile
net/curl/patches/100-wolfssl.patch [deleted file]
net/curl/patches/200-no_docs_tests.patch

index 5e7e554d7b41c3b32ae4a9172f8edc8877ab348e..afb7f815190e6bbf794c7091b1d2398ad9271e2b 100644 (file)
@@ -4,7 +4,7 @@ comment "SSL support"
 
 choice
        prompt "Selected SSL library"
-       default LIBCURL_MBEDTLS
+       default LIBCURL_WOLFSSL
 
        config LIBCURL_MBEDTLS
                bool "mbed TLS"
index 827af43d224c703acd4022d7e7d7a877be6ad8a3..8459ece611faa578416975eb067a9d5ec6a5f081 100644 (file)
@@ -8,14 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.83.1
+PKG_VERSION:=7.85.0
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
-       https://curl.askapache.com/download/ \
+PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(PKG_VERSION:.=_)/ \
        https://curl.se/download/
-PKG_HASH:=2cb9c2356e7263a1272fd1435ef7cdebf2cd21400ec287b068396deb705c22c4
+PKG_HASH:=88b54a6d4b9a48cb4d873c7056dcba997ddd5b7be5a2d537a4acb55c20b04be6
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
diff --git a/net/curl/patches/100-wolfssl.patch b/net/curl/patches/100-wolfssl.patch
deleted file mode 100644 (file)
index d395a07..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/m4/curl-wolfssl.m4
-+++ b/m4/curl-wolfssl.m4
-@@ -93,6 +93,7 @@ if test "x$OPT_WOLFSSL" != xno; then
-    They are set up properly later if it is detected.  */
- #undef SIZEOF_LONG
- #undef SIZEOF_LONG_LONG
-+#include <wolfssl/options.h>
- #include <wolfssl/ssl.h>
-       ]],[[
-         return wolfSSL_Init();
index 463aeac0b026da5fe06e65a2e4c3a7522fc956f3..863c82801df0ea9b628d689ddf9103e64d3da016 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -155,7 +155,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
+@@ -158,7 +158,7 @@ CLEANFILES = $(VC10_LIBVCXPROJ) $(VC10_S
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src
@@ -9,7 +9,7 @@
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -269,8 +269,6 @@ cygwinbin:
+@@ -272,8 +272,6 @@ cygwinbin:
  # We extend the standard install with a custom hook:
  install-data-hook:
        (cd include && $(MAKE) install)