libreswan: kernel module fix 8653/head
authorLucian Cristian <lucian.cristian@gmail.com>
Thu, 11 Apr 2019 07:31:51 +0000 (10:31 +0300)
committerLucian Cristian <lucian.cristian@gmail.com>
Thu, 11 Apr 2019 07:31:51 +0000 (10:31 +0300)
use the kernel arch for building the modules

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
net/libreswan/Makefile

index 556e20fdaaf9ab6d66ba4a9e5b467b54b2e8a973..514c3495993846e648e7bd77f3aa7a583e6e5c71 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libreswan
 PKG_VERSION:=3.27
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://download.libreswan.org/
@@ -90,6 +90,7 @@ MAKE_FLAGS+= \
     USE_SYSTEMD_WATCHDOG=false \
     INC_USRLOCAL="/usr" \
     FINALRUNDIR="/var/run/pluto" \
+    ARCH="$(LINUX_KARCH)" \
     KERNELSRC="$(LINUX_DIR)"
 
 define Build/Prepare