luci-app-simple-adblock: change style of button to important 1969/head
authorStan Grishin <stangri@melmac.net>
Fri, 20 Jul 2018 02:34:49 +0000 (19:34 -0700)
committerStan Grishin <stangri@melmac.net>
Fri, 20 Jul 2018 02:34:49 +0000 (19:34 -0700)
Signed-off-by: Stan Grishin <stangri@melmac.net>
applications/luci-app-simple-adblock/Makefile
applications/luci-app-simple-adblock/luasrc/model/cbi/simple-adblock.lua

index fa98f8e0f45cfae0f10d0ff72ac31903880ff2d3..8d2055829269d9a1bd31f5d71c7425dc24fbc2a6 100644 (file)
@@ -10,7 +10,7 @@ LUCI_TITLE:=Simple Adblock Web UI
 LUCI_DESCRIPTION:=Provides Web UI for simple-adblock service.
 LUCI_DEPENDS:=+luci-mod-admin-full +simple-adblock
 LUCI_PKGARCH:=all
-PKG_RELEASE:=14
+PKG_RELEASE:=15
 
 include ../../luci.mk
 
index aa62ff56c06816301f6801d134457badbfe1b011..4dbb21c6edd9cfae3f029156fa6cd6fb42ad6557 100644 (file)
@@ -24,7 +24,7 @@ else
        if enabledFlag ~= "1" or status:match("Stopped") then
                en.title      = translate("Service is disabled/stopped")
                en.inputtitle = translate("Enable/Start")
-               en.inputstyle = "apply"
+               en.inputstyle = "apply important"
                if nixio.fs.access("/var/simple-adblock.cache") then
                        ds = h:option(DummyValue, "_dummy", translate("Service Status"))
                        ds.template = "simple-adblock/status"
@@ -33,7 +33,7 @@ else
        else
                en.title      = translate("Service is enabled/started")
                en.inputtitle = translate("Stop/Disable")
-               en.inputstyle = "reset"
+               en.inputstyle = "reset important"
                ds = h:option(DummyValue, "_dummy", translate("Service Status"))
                ds.template = "simple-adblock/status"
                ds.value = status
@@ -41,7 +41,7 @@ else
                        reload = h:option(Button, "__reload")
                        reload.title      = translate("Service started with error")
                        reload.inputtitle = translate("Reload")
-                       reload.inputstyle = "apply"
+                       reload.inputstyle = "apply important"
                        function reload.write()
                                luci.sys.exec("/etc/init.d/simple-adblock reload")
                                luci.http.redirect(luci.dispatcher.build_url("admin/services/" .. packageName))