merge r12960 to 8.09 (closes: #4756), bump release number
authorNicolas Thill <nico@openwrt.org>
Fri, 10 Apr 2009 14:57:41 +0000 (14:57 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 10 Apr 2009 14:57:41 +0000 (14:57 +0000)
SVN-Revision: 15207

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.init

index 6051db9d71b3be26001fffc76dee3010c1483c6a..3ab27c2bb83270a7b0bf0692eaca6177af2a9eb1 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.46
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 4fddc4723289d10854c7f61ad7bbfc60f838d023..7d32be077efcfbc1b0bb895becd5c8ab5e56eacd 100644 (file)
@@ -52,6 +52,7 @@ dnsmasq() {
        append_bool "$cfg" dbus "-1"
        append_bool "$cfg" boguspriv "-b"
        append_bool "$cfg" expandhosts "-E"
+       append_bool "$cfg" enable_tftp "--enable-tftp"
 
        append_parm "$cfg" dnsforwardmax "-0"
        append_parm "$cfg" port "-p"
@@ -63,6 +64,8 @@ dnsmasq() {
        append_parm "$cfg" "local" "-S"
        append_parm "$cfg" "leasefile" "-l"
        append_parm "$cfg" "resolvfile" "-r"
+       append_parm "$cfg" "tftp_root" "--tftp-root"
+       append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
 
        config_get leasefile $cfg leasefile
        [ -e "$leasefile" ] || touch "$leasefile"