ices: import from old packages feed
authorNicolas Thill <nico@openwrt.org>
Tue, 17 Feb 2015 06:49:01 +0000 (07:49 +0100)
committerNicolas Thill <nico@openwrt.org>
Tue, 17 Feb 2015 06:49:01 +0000 (07:49 +0100)
 - update to latest version (v2.0.2)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
multimedia/ices/Makefile [new file with mode: 0644]

diff --git a/multimedia/ices/Makefile b/multimedia/ices/Makefile
new file mode 100644 (file)
index 0000000..a3cb714
--- /dev/null
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+# Copyright (C) 2009 Freifunk Leipzig
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ices
+PKG_VERSION:=2.0.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ices/
+PKG_MD5SUM:=832c448cc993170a70fd95804fcda5b2
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ices
+  SECTION:=sound
+  CATEGORY:=Sound
+  TITLE:=ices client for Icecast media streaming servers
+  URL:=http://www.icecast.org/ices/
+  DEPENDS:=+libshout +libxml2 +zlib +libogg +libvorbis +alsa-lib
+endef
+
+define Package/ices/description
+  ices is a command line source client for Icecast media streaming servers.
+  It began as the successor of the old "shout" utility, and has since gained a
+  lot of useful features.
+endef
+
+CONFIGURE_ARGS+= \
+       --with-ogg="$(STAGING_DIR)/usr/include" \
+       --with-vorbis="$(STAGING_DIR)/usr/include" \
+
+define Package/ices/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ices $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,ices))