i2c-tools: Prepare for new Python build process
authorJeffery To <jeffery.to@gmail.com>
Tue, 7 Mar 2023 05:38:07 +0000 (13:38 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 24 Apr 2023 08:20:32 +0000 (16:20 +0800)
This sets build options and adds a call to Py3Build/Install to prepare
for the new Python build process.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
utils/i2c-tools/Makefile

index 8b1563c2ef0cee8b432a04d70beec9c36c31e370..f1a871dd99946cb78cd06dcb972eaf8e5183c2c8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=i2c-tools
 PKG_VERSION:=4.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/utils/i2c-tools
@@ -69,6 +69,8 @@ endef
 
 PYTHON3_PKG_SETUP_ARGS:=
 PYTHON3_PKG_SETUP_DIR:=py-smbus
+PYTHON3_PKG_WHEEL_NAME:=smbus
+PYTHON3_PKG_WHEEL_VERSION:=1.1
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -86,6 +88,10 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/lib/libi2c.{a,so*} $(1)/usr/lib/
 endef
 
+define Build/Install
+       $(call Py3Build/Install)
+endef
+
 define Package/libi2c/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib/libi2c.so* $(1)/usr/lib/